ETP non working

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
eagleeyez
Posts: 16
Joined: Thu Mar 17, 2016 3:58 pm

ETP non working

Post by eagleeyez » Mon Oct 10, 2016 6:47 am

Hi David

I want to report a few bugs

The last versions of Everything after 1.4.413b the ETP connection isn't working client side (I can connect if I start an old version and get it connected to the latest versions) so it guess it is broken in that part only, the server remain working properly in all consecutive version until the latest Version 1.4.1.765b (x64) but not the client

I also found an issue since old version that remains (1.3 / 1.4) that consists in not opening the folders when I select to show the Drive letter instead of server/c on the client side... while if I I copy the path and paste in explorer address bar I can access to that folder, but it will be much practical if this get solved so opening the filers path and folders become seamless and faster.

Thank you for the frequency of latest releases, I love all the added features and I will try to suggest some that I think will make it even better soon.

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: ETP non working

Post by void » Mon Oct 10, 2016 7:18 am

The last versions of Everything after 1.4.413b the ETP connection isn't working client side (I can connect if I start an old version and get it connected to the latest versions) so it guess it is broken in that part only, the server remain working properly in all consecutive version until the latest Version 1.4.1.765b (x64) but not the client
What happens when you try to connect?

Please try running Everything in debug mode:
  • In Everytihng, press Ctrl + `
  • What is displayed in the debug console when you try to connect to your ETP server?
Please make sure the ETP server port is not already in use.
I also found an issue since old version that remains (1.3 / 1.4) that consists in not opening the folders when I select to show the Drive letter instead of server/c on the client side... while if I I copy the path and paste in explorer address bar I can access to that folder, but it will be much practical if this get solved so opening the filers path and folders become seamless and faster.
Please try using the rewrite patterns in Everything 1.4:
http://www.voidtools.com/support/everyt ... e_patterns

Please let me know if you need help with this.

SuperDude
Posts: 96
Joined: Thu Sep 25, 2014 7:57 pm

Re: ETP non working

Post by SuperDude » Mon Oct 10, 2016 8:44 pm

"The last versions of Everything after 1.4.413b"

Where is the newest BETA version's download link (or the page it's on)? Thanks.

galneon
Posts: 27
Joined: Sun Jun 02, 2013 1:36 am

Re: ETP non working

Post by galneon » Mon Oct 10, 2016 9:08 pm

Here are the latest versions:

http://www.voidtools.com/Everything-1.4.1.767b.x86.zip

http://www.voidtools.com/Everything-1.4.1.767b.x64.zip

Save the link of whichever (x86, x64) you use. From time to time, paste the link and go up one or two numbers (768b, 769b, etc.) to get newer version. Keep going till you get a 404 error. void uploads a lot of new builds, he just doesn't always publicize them, but the naming convention is consistent so you need only change the build number to see if a newer version is available.

SuperDude
Posts: 96
Joined: Thu Sep 25, 2014 7:57 pm

Re: ETP non working

Post by SuperDude » Mon Oct 10, 2016 9:27 pm

Thanks for the info. I already have Everything v1.4.1.767b (64-bit), and I also find new versions using the naming convention consistency thing. I was asking about version "1.4.413b" mentioned in the post. I like to always have the latest version so I just wondering where it was. I tried using the search function on this site, but it didn't find it.

galneon
Posts: 27
Joined: Sun Jun 02, 2013 1:36 am

Re: ETP non working

Post by galneon » Mon Oct 10, 2016 9:30 pm

eagleeyez was referring to 1.4.0.713b which is available on the main download page. Needless to say, it's quite old.

A newer version than what we have would be called something like 1.4.2.768b if the .1 was to be incremented, as the build number will always increase.

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: ETP non working

Post by void » Tue Oct 11, 2016 2:49 am

1.4.0.713b is the latest public beta.

I'll post nightly builds here.
Please make sure the ETP server port is not already in use.
This is critical, if Everything binds successfully to at least one interface to your specified port then Everything will think the ETP server is created successfully. It could be possible the ip4 or ip6 interface already has your port in use.

Either try a new port or specify the interface in Everything under Tools -> Options -> ETP/FTP Server -> Bind to Interfaces -> Set to your local ip address.

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Sun Jul 23, 2017 6:20 pm

Hi, David.

I'm trying to understand why I cannot connect Everything to my cellphone via FTP.
I'm using Wi-Fi FTP apps.
It serves 192.168.1.7 IP at port 2221 (default).
App won't allow to use port 21. It asks range for 1024 to 65536.

I can connect to it using DirectoryOpus FTP client with no user nor password, but can't with Everything ETP.
Filling fields like this:
Server 192.168.1.7
Port 2221
User none
Pass none
Link type (all fail)
Any ideas?

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Sun Jul 23, 2017 6:26 pm

Appending...
In fact, I do connect to cellphone, but any search renders none result.
I realized that I was connected right now because I closed cellphone server and Everything raises an error.
:)

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: ETP non working

Post by void » Mon Jul 24, 2017 1:13 am

Can you connect to the Everything FTP server with your webbrowser with the following address:
ftp://192.168.1.7:2221

Please send the debug output after you try to connect to the Everything FTP server with your phone:
  • In Everything, type in the following search and press ENTER:
    /search
  • Attempt to connect to the Everything FTP server with your phone.
  • What is displayed in the Everything debug console?

NotNull
Posts: 2691
Joined: Wed May 24, 2017 9:22 pm

Re: ETP non working

Post by NotNull » Mon Jul 24, 2017 4:29 pm

Gabarito wrote:Appending...
In fact, I do connect to cellphone, but any search renders none result.
I realized that I was connected right now because I closed cellphone server and Everything raises an error.
:)
So you are using Everything as an FTP client to connect to an FTP server running on your phone? :-S

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Mon Jul 24, 2017 6:09 pm

Thank you for your kind and prompt response.
void wrote:Can you connect to the Everything FTP server with your webbrowser with the following address:
ftp://192.168.1.7:2221
Yes, I can.
But no way to search files or delete them with webbrowser...
void wrote: Please send the debug output after you try to connect to the Everything FTP server with your phone:
  • In Everything, type in the following search and press ENTER:
    /search
  • Attempt to connect to the Everything FTP server with your phone.
  • What is displayed in the Everything debug console?
Part of debug log where I can see IP number:

Code: Select all

WM_ACTIVATE 0000000000000001 0000000000260bc4, lastfocus 0000000000190b78, curre
nt focus 0000000000260bc4
connecting to 192.168.1.6:2221
connecting... family 2
new results
WM_ACTIVATE 0000000000000000 0000000000000000, lastfocus 0000000000190b78, curre
nt focus 0000000000190b78
update index C:
Full log file attached, before stop it:
(Attached debug.jpg, but it's actually a TXT file, because forum won't accept TXT or LOG extensions... :))

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Mon Jul 24, 2017 6:13 pm

Gabarito wrote: Full log file attached, before stop it:
(Attached debug.jpg, but it's actually a TXT file, because forum won't accept TXT or LOG extensions... :))
Where is attached file?
By the way, how to attach TXT files?

Debug log file now is at Pastebin.

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Mon Jul 24, 2017 6:25 pm

NotNull wrote: So you are using Everything as an FTP client to connect to an FTP server running on your phone? :-S
Do you know a better way to search all file on your phone except Everything?
:)

Perhaps I'm playing a fool here, but I tried too hard to put it on my HomeGroup without success...
Network is always a nightmare...
So, I took ftp route.

If you want to guide me to achieve that HomeGroup, it would be great!

NotNull
Posts: 2691
Joined: Wed May 24, 2017 9:22 pm

Re: ETP non working

Post by NotNull » Mon Jul 24, 2017 9:05 pm

Gabarito wrote:
NotNull wrote: So you are using Everything as an FTP client to connect to an FTP server running on your phone? :-S
Do you know a better way to search all file on your phone except Everything?
:)
Don't think Everything can index FTP servers. In Windows you can map an FTP server natively (*), but that is done through a "virtual" filesystem. Everything can't index that (AFAIK).

Some alternatives:
[*] Download one of those (Windows) utilities that can map an FTP server to a driveletter. This will be accessible to Everything.
[*] Instaed of an FTP server, run a WebDAV server on your phone. Windows has native support for WebDAV an can map this as a drive.
I'm not a big fan of WebDAV (security, instability), but it is simple and will do the trick.
[*] Run a SMB (/Samba) server on your phone. There are apps for that, too. You can index \\server\share or create a drive mapping

In all these cases, use Folder Indexing in Everything.



(*) Map network drive > Connect to a Web site .....

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Tue Jul 25, 2017 9:54 am

@NotNull,

I'll try your suggestions. Thanks.

And what about to connect through HomeGroup-LocalNetwork?
Not possible?

NotNull
Posts: 2691
Joined: Wed May 24, 2017 9:22 pm

Re: ETP non working

Post by NotNull » Tue Jul 25, 2017 11:19 am

Disclaimer: I stripped HomeGroup functionality from my Windows, so these are just thoughts ..
(and I'm too lazy to test it on another machine :-) )

HomeGroup on your Windows machine creates a "server", where other Windows machines can connect to. There are Android apps that can act as a "Homegroup client" and connect that way to your Windows machine.
If you had an app like Everything on your Android, you could probably index your Windows machine that way.

But AFAIK there is no Android app that can act as a Homegroup *server*, so you can't connect from your Windows machine (acting as a Homegroup client) to your Android device that way.
Not possible?
Long story short: No, not possible.

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Tue Jul 25, 2017 12:38 pm

NotNull wrote:
Not possible?
Long story short: No, not possible.
Thank you, NotNull.
It acts to me as a relief, thinking I'm not so dumb I thought I was.
I tried it too much without success.
Image

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Wed Jul 26, 2017 6:34 pm

void wrote:Please send the debug output after you try to connect to the Everything FTP server with your phone:
Still waiting some suggestions from you, David, after had sent log file.

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Fri Jul 28, 2017 6:26 pm

Reporting back:
NotNull wrote: Some alternatives:
[*] Download one of those (Windows) utilities that can map an FTP server to a driveletter. This will be accessible to Everything.
I'm using ftp client from Directory Opus, an WindowsExplorer "like" program.
I can connect to phone using Opus ftp, but cannot using Everything ETP, with same parameters...
Opus doesn't map to a driveletter. It shows contents of ftp server at its panel.
NotNull wrote: [*] Instaed of an FTP server, run a WebDAV server on your phone. Windows has native support for WebDAV an can map this as a drive.
I'm not a big fan of WebDAV (security, instability), but it is simple and will do the trick.
Installed WebDAV and it gives a IP like this:
192.168.1.9:8080.
This way, I can connect using web browser (Firefox), but cannot using Opus or Everything.
Both stills "waiting to connect" but never ends.
NotNull wrote: [*] Run a SMB (/Samba) server on your phone. There are apps for that, too. You can index \\server\share or create a drive mapping
Installed Samba app.
Openning app it says "SuperUser test failed".
I did not "root" my phone yet because afraid to drives it to crash or other damages.
NotNull wrote: In all these cases, use Folder Indexing in Everything.
Hoping one of tricks can do that.
My goal is just to browse all files on the phone at once, without folder and subfolder view (one by one).

And make run Everything ETP with phone files.

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Fri Jul 28, 2017 6:33 pm

Apending that I already can connect using Wi-Fi FTP App using Opus, as I already said at Sun Jul 23, 2017 6:20 pm above.
It allows to connect using Opus and Firefox.
The final step is to run Everything ETP.

NotNull
Posts: 2691
Joined: Wed May 24, 2017 9:22 pm

Re: ETP non working

Post by NotNull » Sat Jul 29, 2017 9:32 am

The final step is to run Everything ETP
Not possible. Your can't run an ETP server on your Android.
Installed Samba app.
Openning app it says "SuperUser test failed".
There are other SMB apps that don't need root.

I can connect to phone using Opus ftp, but cannot using Everything ETP, with same parameters...
You don't need Opus for that. An FTP client is embedded in Explorer (the filemanager).
As stated before:
Map network drive > Connect to a Web site .....


I did a test for you with one of the utilities that map a FTP server connection as a Windows drive.
I used FTPuse for that (just because I already had it lying around on my system), but other utilities will do too.
(link: https://www.ferrobackup.com/map-ftp-as-disk.html )

Did a

Code: Select all

 ftpuse.exe X: <IP-adress Android device> /PORT:2121
(more options available. See documentation or run ftpuse.exe /?)

and got an extra X:-drive on my system.
Indexed that X:-drive with Everything and got this:
2017-07-28 21_21_21-x_ - Everything.png
2017-07-28 21_21_21-x_ - Everything.png (24.73 KiB) Viewed 4419 times

Gabarito
Posts: 20
Joined: Thu Apr 25, 2013 4:20 pm

Re: ETP non working

Post by Gabarito » Sat Jul 29, 2017 12:12 pm

NotNull wrote: Not possible. Your can't run an ETP server on your Android.
Good to know. Fine.
NotNull wrote: There are other SMB apps that don't need root.
I'll try other app later.
Thx.
NotNull wrote: You don't need Opus for that. An FTP client is embedded in Explorer (the filemanager).
As stated before:
Map network drive > Connect to a Web site .....
Good news!
Best part is that after connect "to a Web site", I can open it using Opus panel and search file and folders using Opus tool for that!
NotNull wrote: I did a test for you with one of the utilities that map a FTP server connection as a Windows drive.
I used FTPuse for that (just because I already had it lying around on my system), but other utilities will do too.

...

and got an extra X:-drive on my system.
Indexed that X:-drive with Everything and got this:
Excellent!!!
Problem solved!
Thank you very much!
:D :D :D

NotNull
Posts: 2691
Joined: Wed May 24, 2017 9:22 pm

Re: ETP non working

Post by NotNull » Sat Jul 29, 2017 3:28 pm

You're welcome!

(And thanks for the feedback. Other users may profit from that .. )

Post Reply