[Solved] Copy hot item's full path to clipboard shortcut copies as unquoted

Discussion related to "Everything" 1.5 Alpha.
Post Reply
aviasd
Posts: 135
Joined: Sat Oct 07, 2017 2:18 am

[Solved] Copy hot item's full path to clipboard shortcut copies as unquoted

Post by aviasd »

Hi
When assigning a shortcut to Result list | Hot Item | Copy full path to clipboard:
1. Pressing the shortcut will copy the path without quotes while the equivalent context menu item copies with quotes.
2. Pressing the shortcut while on a folder will not copy anything to the clipboard, while the equivalent context menu item will. - It does work, but if the UI is updating result lists while I press the shortcut - I.E: while on dm:1m it is not caught on first attempt ( for folder or file )
- Sorry about that - didn't realize hot item was following the mouse and not the currently selected item :oops:
Tested on: Everything-1.5.0.1254a
Thanks.
Last edited by aviasd on Tue Apr 27, 2021 7:23 am, edited 1 time in total.
void
Developer
Posts: 15838
Joined: Fri Oct 16, 2009 11:31 pm

Re: Copy hot item's full path to clipboard shortcut copies as unquoted

Post by void »

Thank you for the feedback aviasd,

To copy paths with double quotes:
  • In Everything, from the Tools menu, click Options.
  • Cilck the Results tab on the left.
  • Check Double quote copy as path.
  • Click OK.
2. Pressing the shortcut while on a folder will not copy anything to the clipboard, while the equivalent context menu item will. - It does work, but if the UI is updating result lists while I press the shortcut - I.E: while on dm:1m it is not caught on first attempt ( for folder or file )
- Sorry about that - didn't realize hot item was following the mouse and not the currently selected item
There is separate commands for selected and hot (mouseover).

I have added a couple new commands for the next alpha update:
A copy path with quotes command.
A copy full path and filename with quotes command.

I have on my TODO list to add the option to choose copy as path with quotes in the Context menu options.
aviasd
Posts: 135
Joined: Sat Oct 07, 2017 2:18 am

Re: Copy hot item's full path to clipboard shortcut copies as unquoted

Post by aviasd »

void wrote: Wed Apr 21, 2021 10:52 am Thank you for the feedback aviasd,

To copy paths with double quotes:
  • In Everything, from the Tools menu, click Options.
  • Cilck the Results tab on the left.
  • Check Double quote copy as path.
  • Click OK.
Yep, it was selected here, although it does not affect - Result list | Hot Item | Copy full path to clipboard - those are still copied without quotes.
void wrote: Wed Apr 21, 2021 10:52 am There is separate commands for selected and hot (mouseover).
I never noticed the hot item actions before, it's really nice..
I have added a couple new commands for the next alpha update:
A copy path with quotes command.
A copy full path and filename with quotes command.

I have on my TODO list to add the option to choose copy as path with quotes in the Context menu options.
Cool! 8-)
void
Developer
Posts: 15838
Joined: Fri Oct 16, 2009 11:31 pm

Re: Copy hot item's full path to clipboard shortcut copies as unquoted

Post by void »

Thank you for the bug report aviasd,

Could you please try the latest Everything 1.5 Alpha.

Everything 1.5.0.1255a fixes an issue with Result list | Hot Item | Copy full path to clipboard and Result list | Hot Item | Copy path clipboard ignoring your double quote copy as path setting.

I have also added some commands under Tools -> Options -> Keyboard to copy paths with double quotes.
aviasd
Posts: 135
Joined: Sat Oct 07, 2017 2:18 am

Re: Copy hot item's full path to clipboard shortcut copies as unquoted

Post by aviasd »

void wrote: Fri Apr 23, 2021 4:51 am Thank you for the bug report aviasd,

Could you please try the latest Everything 1.5 Alpha.

Everything 1.5.0.1255a fixes an issue with Result list | Hot Item | Copy full path to clipboard and Result list | Hot Item | Copy path clipboard ignoring your double quote copy as path setting.

I have also added some commands under Tools -> Options -> Keyboard to copy paths with double quotes.
Thanks,
Confirmed.
Now Result list | Hot Item | Copy full path to clipboard respects with double-quote copy as path setting
Post Reply