Start Everything on System Startup problem

Found a bug in "Everything"? report it here
Post Reply
froggie
Posts: 198
Joined: Wed Jun 12, 2013 10:43 pm

Start Everything on System Startup problem

Post by froggie » Sun Feb 21, 2021 6:43 pm

This is strange.

In Windows 10 Everything does not start on system startup, even though the box is checked.

The identical setup in Windows 7 works as it should (dual boot system, running from the same libraries).

Everything is version 1.4.1.1005 - not admin - 64 bit

In the registry there is a correct entry for Everything at
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
but it does not work.

If I add a registry entry for Everything in at
HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows\CurrentVersion\Run
it works.

This should not be like this for a 64 bit program. What am I missing?

NotNull
Posts: 2863
Joined: Wed May 24, 2017 9:22 pm

Re: Start Everything on System Startup problem

Post by NotNull » Sun Feb 21, 2021 8:14 pm

Strange indeed ...

You probably already tried this, but to be on the safe side:
  • Disable the Start Everything on system startup setting
  • Click the OK button and accept the UAC prompt
  • Enable the Start Everything on system startup setting
  • Click the OK button and accept the UAC prompt
  • Make sure there is a check mark/tick ( ) in the box and that is not a small black square ( )
  • Test.

void
Site Admin
Posts: 6475
Joined: Fri Oct 16, 2009 11:31 pm

Re: Start Everything on System Startup problem

Post by void » Sun Feb 21, 2021 10:12 pm

Please double check the Everything.exe in:
HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
Is not the x86 version (C:\Program Files (x86)) that might be set to run as an administrator.

Windows 10 will not launch programs on startup that are set to run as administrator.

Please try running Everything as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service.
  • Uncheck Run as administrator.
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.
And to run Everything as a standard user:
  • Right click your Everything.exe or a shortcut to Everything
  • Click Properties.
  • Click the Compatibility tab.
  • Uncheck Run this program as an administrator.
  • Click OK.
And also to run Everything as a standard user:
  • Right click your shortcut to Everything
  • Click Properties.
  • Click the Shortcut tab.
  • Click the Advanced button.
  • Uncheck Run as administrator.
  • Click OK.
  • Click OK.
Maybe there is another entry in HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\Run Windows is getting stuck on.
Try setting the Everything entry to C:\Windows\Notepad.exe and see if it launches.

froggie
Posts: 198
Joined: Wed Jun 12, 2013 10:43 pm

Re: Start Everything on System Startup problem

Post by froggie » Mon Feb 22, 2021 12:01 am

Found it! Another layer of windows.

Everything was marked
Disabled
in the startup tab of the task manager. Which is kept in yet another registry key.

Not something I would ever do to Everything, so no idea how that happened.

Thanks @Void, @ NotNull.

void
Site Admin
Posts: 6475
Joined: Fri Oct 16, 2009 11:31 pm

Re: Start Everything on System Startup problem

Post by void » Mon Feb 22, 2021 4:46 am

Nice find!

For everyone else, disabled startup items are stored in:
HKLM\Software\Microsoft\Windows\CurrentVersion\Explorer\StartupApproved\Run
there should be one corresponding entry for each entry in:

\Software\Microsoft\Windows\CurrentVersion\Run

It's a binary value, "02 00 00 00..." means enabled, any other value seems to mean disabled.
https://superuser.com/questions/664641/where-are-disabled-autostart-programs-stored-somewhere-in-the-registry

I have added to my TODO list to check for this registry entry and update it if enabling "run Everything on system startup".

Post Reply