Trying to get an exact file name ignoring also spaces

General discussion related to "Everything".
Post Reply
mjlm
Posts: 5
Joined: Fri Feb 19, 2021 7:51 am

Trying to get an exact file name ignoring also spaces

Post by mjlm » Fri Feb 19, 2021 8:14 am

Hello,

I am trying to search for a given name without any wildcards, that is the exact name without considering the file extension but also without considering spaces that may be. So for example, I want to search and locate the file 'hosts' under c:\Windows\System32\drivers\etc. This file does not have an extension. I have also made a copy of that file named as 'hosts - copy' in the same folder.

Using the following syntax I can get the hosts* files, meaning the actual 'hosts' plus the 'hosts - copy file'.
input string in everything -> hosts c: \etc

Not that it hurts too much seeing both, but I was wondering if I could write it in a way to filter the ...copy instance out. So how could I write it?

Using wfn: & ww: didin't help much.
Any ideas appreciated.

void
Site Admin
Posts: 6540
Joined: Fri Oct 16, 2009 11:31 pm

Re: Trying to get an exact file name ignoring also spaces

Post by void » Fri Feb 19, 2021 8:30 am

wfn:hosts
should do what you want
You might have Match Path enabled under the Search menu, wfn will match the whole path and filename in this case.
Please try:
nopath:wfn:hosts

exact: is the same as wfn: and is easier to remember:
exact:hosts

Regex will give you more control:
regex:^hosts$
^ = match start of filename
$ = match end of filename

If you have many results with extensions, please try !. to match files with no extension:
hosts !.
Using wfn: & ww: didin't help much.
What happens for you? What results do you see?

mjlm
Posts: 5
Joined: Fri Feb 19, 2021 7:51 am

Re: Trying to get an exact file name ignoring also spaces

Post by mjlm » Fri Feb 19, 2021 9:56 am

Thank you for your swift reply.

Please allow me here to describe shortly an other issue that prohibits me to type your suggestions for the main issue. When I type, often I cannot type any further. It is suddenly just stuck and no matter what key I press on my keyboard, nothing appears further in the search field. So the string is semi finished. This doesn't happen always, it s really weird.

About your recommendations,
wfn:hosts works well. I was typing 'hosts wfn:' and couldn't get any results. So c: \etc wfn:hosts works perfectly.

However, when I try c: \etc exact:host, I m stuck to 'c: \etc exact:hos' instead of 'c: \etc exact:host'. I just cant type the t. Like I wrote above I cant just finish the name! No matter what I press nothing comes up.

The same happens with '!. hosts c: \etc'. I can only type '!. hosts c: \e'.

Thank you for your support.

void
Site Admin
Posts: 6540
Joined: Fri Oct 16, 2009 11:31 pm

Re: Trying to get an exact file name ignoring also spaces

Post by void » Fri Feb 19, 2021 10:01 am

Does Everything crash or hang? Are you able to clear the search?

Could be a bad icon shell extension, could you please try disabling shell extensions and see if the issue persists:
  • In Everything, type in the following search and press ENTER:
    /icon_shell_extensions=0
  • If successful, you should see icon_shell_extensions=0 in the status bar for a few seconds.
Does the issue persist?

mjlm
Posts: 5
Joined: Fri Feb 19, 2021 7:51 am

Re: Trying to get an exact file name ignoring also spaces

Post by mjlm » Fri Feb 19, 2021 11:01 am

Unfortunately that didn't help. Here is a video that shows what I type and how the software reacts.

https://we.tl/t-kSwgUb8X0b

At around 27 to 28 sec I m pressing the 't' key but does not show up. I then type some other keys out of frustration which can be seen the status bar at the bottom. The issue is weird. When I try 'c: \etc wfn:hosts' instead, I am able to type it wholly.

Any ides appreciated.

void
Site Admin
Posts: 6540
Joined: Fri Oct 16, 2009 11:31 pm

Re: Trying to get an exact file name ignoring also spaces

Post by void » Fri Feb 19, 2021 11:23 am

Thanks for the video.

Very very odd, have you accidentially bound 's' to something?
It looks like Everything shifts focus to the result list.

If you clear the search box and press s, does Everything focus the result list?

Do you have a script running in the background to tab on certain keypresses?

Could you please check the shortcuts for all your filters:
  • In Everything, from the Search menu, click Organize filters.
  • For each filter:
    • Click Edit....
    • Check Keyboard Shortcut
    • If this is set to S (or maybe some other key?), click on the S and press Backspace.
  • Click OK.

Could you please check your Keyboard shortcuts:
  • In Everything, from the Tools menu, click Options filters.
  • Click the Keyboard tab on the left.
  • Click Add....
  • Press S
  • Is anything shown in the Shortcut key currently used by list?
  • Click Cancel.
  • Click Cancel.
If the issue persists, could you please send me your %APPDATA%\Everything\Everything.ini

Verbose debug logs might be useful:
  • In Everything, type in the following search and press ENTER (copy and paste if you are unable to type it)
    /debug
    This will show the Everything debug console.
    type in the following search and press ENTER
    /verbose
    This will enable verbose debug mode.
    type in c: \etc hosts
    What is shown in the debug console?

To close the debug console:
  • In Everything, type in the following search and press ENTER:
    /debug
It might be a bug with the search history suggestions? -Does the issue persist if you disable Search History from Tools -> Options -> History -> Uncheck Enable Search History.

mjlm
Posts: 5
Joined: Fri Feb 19, 2021 7:51 am

Re: Trying to get an exact file name ignoring also spaces

Post by mjlm » Fri Feb 19, 2021 3:20 pm

Hi, thank you for such a thorough reply.

I did try the following

In Everything, from the Search menu, click Organize filters.
For each filter:
Click Edit....
Check Keyboard Shortcut
If this is set to S (or maybe some other key?), click on the S and press Backspace.
Click OK.
I do have two shortcuts made for quickly switching between documents and pictures. These can be seen assigned if you look closely to the video for a moment where the search menu appears. These are Alt+W & Alt+C. I removed them but no change.

Could you please check your Keyboard shortcuts:

In Everything, from the Tools menu, click Options filters.
Click the Keyboard tab on the left.
Click Add....
Press S
Is anything shown in the Shortcut key currently used by list?
Click Cancel.
Click Cancel.
There is nothing assigned to 's'. When I type as suggested, there isn't something popping up in the 'Shortcut Key currently used by' window. I do use however the LeftWin + Q key to bring up Everything (always in memory). See picture below.
http://ibb.co/xC6WfGn

Here is my ini file.
https://we.tl/t-3OXPafZLYr

I tried your suggestions about the debug console and it is scrolling for ever presumably cycling around something, not sure. It does not come to a stop. Here is a screenshot.

https://we.tl/t-1RPPHsbpFr

I disabled the Search History as suggested but know it seems it stops sooner :?
When I type '!. c: \etc hosts', it only types '!. c: \e' :cry:
When I simply copy and paste the macro string from notepad it works like a charm. Very frustrating!

NotNull
Posts: 2909
Joined: Wed May 24, 2017 9:22 pm

Re: Trying to get an exact file name ignoring also spaces

Post by NotNull » Fri Feb 19, 2021 3:55 pm

In your Everything.ini you defined a keyboard shortcut "T" for Result List | Focus Result List (under menu:Tools > Options > General > Keyboard).

This causes typing a "T" to jump to the result list. Remove that keyboard shortcut and you're good.

mjlm
Posts: 5
Joined: Fri Feb 19, 2021 7:51 am

Re: Trying to get an exact file name ignoring also spaces

Post by mjlm » Fri Feb 19, 2021 5:28 pm

I don't recall having made this shortcut but then again I 'm not young anymore :D

Now it looks working just fine.

Thank you very much for such a comprehensive support, especially for a free software.

Take care.

Post Reply