[FIXED] Losing setting multiple times

Discussion related to "Everything" 1.5 Alpha.
Post Reply
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

[FIXED] Losing setting multiple times

Post by tuska »

Hi,
since Everything-1.5.0.1237a - 13.03.2021, my NTFS drive D: has the status unchecked for option "Include in database"
for the fourth time without my intervention.
 
2021-04-19_NTFS drive D_ NOT in database.png
2021-04-19_NTFS drive D_ NOT in database.png (61.53 KiB) Viewed 27805 times
 
I always notice this when the database size has been greatly reduced -> Everything.db
or when I enter d: in the search box and get no search results for drive D:.

Only the NTFS drive D: is affected, because the settings are retained for all other drives.

The D: drive is one of my three internal NTFS drives (D:, I:, J:).
D: (C:\_Quelle\D-I) and D: (C:\_Quelle\D-J) are junctions with the correct status: [ ] Include in database.
Everything 1.5.0.1254a (x64) is used portably, in the following path: C:\Tools\Everything_1.5\

I would now like to look into this and would appreciate your support.
Thanks!

EDIT:
Maybe I should try this option?
________________________________________________
Windows 10 Pro (x64) Version 20H2 (OS build 19042.928)
'Everything' 1.5.0.1254a (x64)
Last edited by tuska on Fri Jun 25, 2021 9:09 am, edited 1 time in total.
void
Developer
Posts: 14965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Losing setting multiple times

Post by void »

Everything might be seeing the drive as offline occasionally ?

-If the volume is detected as offline, Everything will remove it and perform a quick rebuild.
What is your Tools -> Debug -> Statistics -> Last Rebuild Reason?

Could you please try disabling 'Automatically remove offline volumes':
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically remove offline volumes.
  • Click OK.
Does the issue persist?

Could you please send me your %APPDATA%\Everything\Everything.ini when your volume is included.
Could you please send me your %APPDATA%\Everything\Everything.ini when your volume is lost.
EDIT:
Maybe I should try this option?
Please try disabling the auto_remove_moved_ntfs_volumes option.
auto_remove_moved_ntfs_volumes should already be disabled by default for Everything 1.5.
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

2void
Thank you for your support.
void wrote: Wed Apr 21, 2021 10:27 pm-If the volume is detected as offline, Everything will remove it and perform a quick rebuild.
Everything suspects that the drive is offline and changes the setting, but does not do a quick rebuild on its own.
I notice that when I query e.g. d:, no more folders and files are displayed as search results in Everything.
In my opinion, the D: drive is not offline (just like the other drives I:, J:).
I would like to mention that this problem never existed on my PC in Everything 1.4, but only occurred with Everything 1.5.
void wrote: Wed Apr 21, 2021 10:27 pmWhat is your Tools -> Debug -> Statistics -> Last Rebuild Reason?
Last build date: 19.04.2021 13:06
Last rebuild reason: Add NTFS volume.
Reason: Settings for D: (D:) --> [✓] Include in database --> Tick-checked by me because the drive was not indexed for some reason.
void wrote: Wed Apr 21, 2021 10:27 pmCould you please try disabling 'Automatically remove offline volumes':
Done on 22.4. - Everything-1.5.0.1254a.x64
void wrote: Wed Apr 21, 2021 10:27 pmDoes the issue persist?
I will report on this later - if the error does NOT occur on 20.5. (Status report), otherwise I will report earlier.

History:
...
01.4.2021 Everything-1.5.0.1252a.x64
07.4.2021 Drive D: not in database     (3rd time)
09.4.2021 Everything-1.5.0.1253a.x64
19.4.2021 Drive D: not in database     (4th time)
16.4.2021 Everything-1.5.0.1254a.x64
void wrote: Wed Apr 21, 2021 10:27 pmCould you please send me your %APPDATA%\Everything\Everything.ini when your volume is included.
Done on 22.4.
void wrote: Wed Apr 21, 2021 10:27 pmauto_remove_moved_ntfs_volumes should already be disabled by default for Everything 1.5.
I took this setting from Everything 1.4 and haven't changed it since.

Thanks!
void
Developer
Posts: 14965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Losing setting multiple times

Post by void »

Thanks for the reply and Everything.ini tuska,

Everything has most likely seen your D: drive as offline.
Is there anything in your Event Viewer around the times Everything saw this drive as offline?

Could you please try the latest Everything 1.5 Alpha.

Everything 1.5.0.1255a fixes an issue with remembering included volumes when Automatically remove volumes is checked.
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

void wrote: Fri Apr 23, 2021 4:45 am Everything has most likely seen your D: drive as offline.
Is there anything in your Event Viewer around the times Everything saw this drive as offline?
I could not find anything conspicuous in the event viewer.
Drive D: was displayed as error-free on 7.4. and 19.4.

I now use Everything-1.5.0.1255a.x64 and have ticked this option again:

Code: Select all

NTFS - [✓] Automatically remove offline volumes
Thank you for your efforts!
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

tuska wrote: Thu Apr 22, 2021 2:41 pm
void wrote: Wed Apr 21, 2021 10:27 pmDoes the issue persist?
I will report on this later - if the error does NOT occur on 20.5. (Status report), otherwise I will report earlier.
History (continued) - NTFS drive D:\ ...
23.4.2021 Everything-1.5.0.1255a.x64 (fixed an issue with remembering indexed volumes)
23.4.2021 NTFS - [✓] Automatically remove offline volumes
27.4.2021 Everything-1.5.0.1255a.x64
30.4.2021 Everything-1.5.0.1257a.x64
----------------------------------------------------------------------------------------------
04.5.2021 Everything-1.5.0.1257a.x64 Windows 10 Pro (x64) Version 20H2 (OS build 19042.964)
NTFS - [✓] Automatically remove offline volumes -> Drive D: was not included!
Settings for D: (D:)
[ ] Include in database
[ ] Load recent changes from USN journal
----------------------------------------------------------------------------------------------
04.5.2021 NTFS - [ ] Automatically remove offline volumes
06.5.2021 NTFS - [✓] Automatically remove offline volumes
06.5.2021 Everything 1.5.0.1257a (x64) | Windows 10 Pro (x64) Version 20H2 (OS build 19042.964) | Debug logging enabled
07.5.2021 Everything 1.5.0.1258a (x64)
12.5.2021 Windows 10 Pro (x64) Version 20H2 (OS build 19042.985)
14.5.2021 Everything 1.5.0.1259a (x64)

The error has occurred every 14 days so far:
07.4.2021 Drive D: not in database (3rd time)
19.4.2021 Drive D: not in database (4th time)
04.5.2021 Drive D: not in database ..

I will keep the debug logging switched on and report again later...
therube
Posts: 4528
Joined: Thu Sep 03, 2009 6:48 pm

Re: Losing setting multiple times

Post by therube »

Are multiple different devices being assigned to D: (at various times)?

If so, you might think about assigning a (semi)permanent drive letter to your drives & see if that makes any difference.
Like I set my Corsair to K: & my WesternDigital to W:, Seagate to S:...
So anytime I plug them in, they are seen as K: & W: & S: respectively.

(Assigned drive letters [for removable devices] further down the alphabet are less likely to be reassigned.)
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

therube wrote: Thu May 20, 2021 3:23 pm Are multiple different devices being assigned to D: (at various times)?
No, please also see my first post:
tuska wrote: Mon Apr 19, 2021 10:17 am ... Only the NTFS drive D: is affected, because the settings are retained for all other drives. ...
... The D: drive is one of my three internal NTFS drives (D:, I:, J:). ...
This did not happen in Everything 1.4.

I do not want to change the drive letter D: at all,
because I need it for multiple synchronisations for backup purposes.

If this error occurs again, I will make the file
C:\Users\<User>\AppData\Local\Temp\Everything Debug Log.txt
available to the author.

Thanks!
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

tuska wrote: Thu May 20, 2021 4:32 pm If this error occurs again, I will make the file
C:\Users\<User>\AppData\Local\Temp\Everything Debug Log.txt
available to the author.
Done on 25.5.2021.

________________________________________________
Windows 10 Pro (x64) Version 20H2 (OS build 19042.985)
'Everything' 1.5.0.1261a (x64)
void
Developer
Posts: 14965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Losing setting multiple times

Post by void »

Thank you for the debug logs tuska,

I can confirm there is an issue.
Everything is forgetting the volume when Everything is unable to determine the file system format (eg: NTFS).

It's odd that Everything detected the volume as NTFS, then one second later Everything fails to detect it as NTFS (access denied).
Almost as if something is locking the drive (defragger? backup?), or Windows is using a cached handle somewhere from another user...

I'm rewriting volume detection code for the next alpha update of Everything.

I will have something to test in the next couple days..
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

void wrote: Wed May 26, 2021 9:49 am Almost as if something is locking the drive (defragger? backup?),
or Windows is using a cached handle somewhere from another user...
Not that I know of.
void
Developer
Posts: 14965
Joined: Fri Oct 16, 2009 11:31 pm

Re: Losing setting multiple times

Post by void »

Thank you for the info tuksa,

Everything 1.5.0.1262a fixes an issue with Everything forgetting drives when it is unable to determine the file system format.

Please disable debug logging for now:
  • In Everything, type in the following search and press ENTER:
    /debug_log=0
  • If successful, you should see debug_log=0 in the status bar for a few seconds.
Please let me know if the issue occurs again.
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

Thanks a lot! :)

After the unexpected behavior has occurred so far so about every 2-3 weeks,
I would report to this topic again in 4 weeks, as on 25.6.

If, contrary to expectations, the setting should be lost after all, then I'll get back to you sooner.
tuska
Posts: 898
Joined: Thu Jul 13, 2017 9:14 am

Re: Losing setting multiple times

Post by tuska »

void wrote: Fri May 28, 2021 8:19 am Everything 1.5.0.1262a fixes an issue with Everything forgetting drives when it is unable to determine the file system format.
Everything-1.5.0.1261a.x64: Last time the error occurred on 25.5.2021 with this version -> "Drive D: not in database"
Everything 1.5.0.1262a.x64: 28.05.2021 improved volume detection | debug logging disabled

After that I installed every alpha version on the day of release and used Everything daily.

Since Everything 1.5.0.1262a (x64) from 28.5.2021 the problem did not occur,
i.e. the problem has not occurred for the last 4 weeks.

With this I consider the problem as fixed. :-)
Thank you for your endeavours!

____________________________________________________________________________
'Everything' 1.5.0.1265a (x64) | Windows 10 Pro (x64) Version 21H1 (OS build 19043.1081)
Post Reply