Copy paste Bug?

Discussion related to "Everything" 1.5 Alpha.
Post Reply
midigator
Posts: 10
Joined: Sat Oct 04, 2014 2:12 pm

Copy paste Bug?

Post by midigator »

Hello dear Dev,

I work with notepad++
I try to change the encoding to ANSI, UTF-8
This is not change the problem

Now here a sample of searching Criteria
parent:"C:\Program Files" "Common Files"
parent:"C:\Program Files (x86)" "Common Files"

When I paste tihs in Version 1.5.0.1358a (x64)
Result:
<<parent:"C:\Program Files" "Common Files">|<parent:"C:\Program Files (x86)" "Common Files">>

When I paste tihs in Version 1.5.0.1359a (x64)
Result:
<<parent:&quot:C:\Program Files&quot: &quot:Common Files&quot:>|<parent:&quot:C:\Program Files (x86)&quot: &quot:Common Files&quot:>>

All same computer tuning
Just changing from 1.5.0.1358a to 1.5.0.1359a and Vice-Versa
The problem appear.

Thank you for your greatefull works
void
Developer
Posts: 15804
Joined: Fri Oct 16, 2009 11:31 pm

Re: Copy paste Bug?

Post by void »

Thank you for your feedback midigator,



The issue is related to this change:

Everything 1.5.0.1359a escapes search operators when pasting multi-line text.



I am going to revert this change and add an option to paste text as filenames with search operators escaped.
The option to paste text as filenames will be off by default.

Ideally, text should be pasted as is.
Everything shouldn't do any processing on the text by default.



I'll have a fix soon.
midigator
Posts: 10
Joined: Sat Oct 04, 2014 2:12 pm

Re: Copy paste Bug?

Post by midigator »

Thank you VOID,
You are my Hero
Always the fastest on rescue.

Have a good end of WE
void
Developer
Posts: 15804
Joined: Fri Oct 16, 2009 11:31 pm

Re: Copy paste Bug?

Post by void »

Everything 1.5.0.1360a reverts the multi-line filename paste.

Multi-line text is now pasted as is with no formatting applied.
(other than the OR operator for each lines)



To set the multi-line paste type:
  • In Everything 1.5, from the Tools menu, click Options.
  • Click the Advanced tab on the left.
  • To the right of Show settings containing, search for:
    paste
  • Select paste_multiline_type.
  • Set the value to: Filename
    (the default is: Search)
  • Click OK.
paste_multiline_type
Post Reply