Bug in Formula

Discussion related to "Everything" 1.5 Alpha.
Post Reply
nikov
Posts: 131
Joined: Fri Dec 24, 2021 10:31 am

Bug in Formula

Post by nikov »

Code: Select all

columna:=0||1 addcolumn:columna
outputs [0] but it should output [1].

Thanks.
void
Developer
Posts: 15797
Joined: Fri Oct 16, 2009 11:31 pm

Re: Bug in Formula

Post by void »

Thank you for the bug report nikov,



Everything doesn't eat the | with columna:=

Everything is currently treating this as:

columna:=0 | | 1 addcolumn:columna
(columna:=0 OR everything OR 1) addcolumn:columna



I will trial eating | with columna:= in the next alpha update.

For now, please try:

columna:=eval("0||1")
void
Developer
Posts: 15797
Joined: Fri Oct 16, 2009 11:31 pm

Re: Bug in Formula

Post by void »

nikov
Posts: 131
Joined: Fri Dec 24, 2021 10:31 am

Re: Bug in Formula

Post by nikov »

void wrote: Thu May 09, 2024 7:01 am

The following search is not working:

Code: Select all

#eval:0||1

Also, the following command is not working:

Code: Select all

Everything64.exe -search "#eval:0||1"

Is it intended that "#eval:0||1" should be replaced with "#[eval:0||1]" in the above cases?
But then there should be notes/cautions indicating how not to use these notations and how to handle and escape these notations.

I also tested "columna:=eval("0||1")" method; don't know about its cons yet but till now not found any problem.

Thank you.
void
Developer
Posts: 15797
Joined: Fri Oct 16, 2009 11:31 pm

Re: Bug in Formula

Post by void »

Thank you for testing 1374a nikov,

Everything 1.5.0.1375a improves #eval:

#eval: will now eat pipes (|)

#eval:0||1

Alternative syntax:

#eval:"0||1"
#[eval:0||1#]:
nikov
Posts: 131
Joined: Fri Dec 24, 2021 10:31 am

Re: Bug in Formula

Post by nikov »

void wrote: Fri May 10, 2024 3:58 am
Thank you for the fixes,
They seem to work nice till now.
Post Reply