Wildcard searches not working

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
Nnyan
Posts: 2
Joined: Thu May 21, 2009 3:53 pm

Wildcard searches not working

Post by Nnyan » Thu May 21, 2009 4:08 pm

Hello everyone,

Got a weird problem. When do a wildcard search in Everything ex: *.ISO I'm not getting any results. Further if I search for ex: M*.ISO I get a ton of results even those that do not have an M in their names. Now if I access everything via the web (http://localhost:8080) the searches work just fine.

Thank you for your time

David
Site Admin
Posts: 430
Joined: Tue Mar 17, 2009 1:42 am

Re: Wildcard searches not working

Post by David » Fri May 22, 2009 8:02 am

What search options do you have enabled in the Search menu?

coryg
Posts: 1
Joined: Wed Jun 17, 2009 1:07 pm

Re: Wildcard searches not working

Post by coryg » Wed Jun 17, 2009 1:17 pm

I am having a similar problem. I did a search for *.n2k and nothing comes up, doing a search for n2k does not show any *.n2k files (several *.n2k files exist in my application Data\Microsoft\outlook folder). I have nothing excluded and no options selected on the search menu. Other files in the folder where the N2K files exist show up. If I search for the file name by name before the .N2K then they show up in the results. Other wildcards seem to work (like *.ISO) not sure why *.N2K is not working.

daspud
Posts: 102
Joined: Wed Apr 01, 2009 3:15 am

Re: Wildcard searches not working

Post by daspud » Thu Jun 18, 2009 3:00 am

try using .n2k (without the star). I have found that using that gives me more consistent results.

I just did a small test and *.wmv returned 269 entries while .wmv returned 279. I exported both sets of results and found that the *.wmv EXcluded all the LNK files (xxxxxx.wmv.lnk). that makes sense since wmv was not the final extension.

Bob Roos

David
Site Admin
Posts: 430
Joined: Tue Mar 17, 2009 1:42 am

Re: Wildcard searches not working

Post by David » Thu Jun 18, 2009 3:52 am

Please make sure Regex is disabled.

To disable regex:
  • From the Search menu, uncheck Enable Regex.
Please make sure match case is disabled.

To disable match case:
  • From the Search menu, uncheck Match Case.

raywood
Posts: 11
Joined: Fri Apr 29, 2011 7:42 pm

Re: Wildcard searches not working

Post by raywood » Fri Apr 29, 2011 7:52 pm

Since my search for "asterisk" turned up nothing, I thought I'd just mention that this particular thread provided the answer to my own quandary as to the proper use of the asterisk as a wild card. May also be of interest to those who question the question mark.

Post Reply