[Bug Report] Some video files' properties are not properly displayed

Discussion related to "Everything" 1.5 Alpha.
Post Reply
HASJ
Posts: 6
Joined: Thu Oct 26, 2017 4:39 pm

[Bug Report] Some video files' properties are not properly displayed

Post by HASJ » Wed Apr 07, 2021 11:55 pm

WMV, MPG, MOV, TS, M4V, ASF are the ones that I noticed. Length is either "00:00" or empty. Height is empty in some of those.
The files are playable normally and both MediaInfo and FFmpeg are able to retrieve the files' information without any errors.

void
Site Admin
Posts: 6679
Joined: Fri Oct 16, 2009 11:31 pm

Re: [Bug Report] Some video files' properties are not properly displayed

Post by void » Thu Apr 08, 2021 12:22 am

Thank you for your feedback HASJ,

Here are the file types with native support in Everything.

I'll add MOV, TS, M4v and ASF to my list to support.

For now, you will need a third party Property System handler to retrieve meta data for these file types.

therube
Posts: 2906
Joined: Thu Sep 03, 2009 6:48 pm

Re: [Bug Report] Some video files' properties are not properly displayed

Post by therube » Thu Apr 08, 2021 2:52 pm

Note that a "0.00" or blank may be an indicator of an "issue" with a particular file.

(Sometimes running the file through a [ffmpeg] copy operation "rights" it.
ffmpeg.exe -i xxx.asf -c copy out.asf
)

Also worth noting what Windows itself may say about a particular file.

(MOV, I'm pretty sure, properties simply are not seen.)

therube
Posts: 2906
Joined: Thu Sep 03, 2009 6:48 pm

Re: [Bug Report] Some video files' properties are not properly displayed

Post by therube » Fri Apr 09, 2021 2:37 pm

(MOV, I'm pretty sure, properties simply are not seen.)
Nope, that's wrong.
In general, MOV (Properties) should be seen - though particular codecs within the MOV might not be (like Sorenson).

Post Reply