[1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Discussion related to "Everything" 1.5 Alpha.
Post Reply
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

[1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

Code: Select all

Name:   	   Dateiausschlüsse...  !<C:|I:|J:>  MAKRO cij: | ALT+> (OEM 102) = Sämtliche Laufwerke!
Search: 	   !<C:|I:|J:>
Macro:  	   cij
Keyboard shortcut: ALT+Y
("Indexing properties" is running, but the other filters work without any problems).

Please check.
Thank you!

____________________________________________________________________________
Windows 10 Pro (x64) Version 20H2 (OS build 19042.867)
'Everything'-1.5.0.1238a (x64) | Portable on Systemdrive C: in C:\Tools\Everything_1.5\
'Everything'-Version 1.4.1.1007 (x64) | Portable on Systemdrive C: in C:\Tools\Everything\
NotNull
Posts: 5317
Joined: Wed May 24, 2017 9:22 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by NotNull »

tuska wrote: Sat Mar 13, 2021 5:37 pmPlease check.
I did :)

Works here. Either through selecting the filter from the filterbar or by typing cij: in the searchbox or by pressing CTRL+/
(CTRL+\ is in use here)
Do you get no results at all? Or unexpected results? (I assume you have other volumes beside C:, I: and J: ?)
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

Thanks for checking! :)

This filter should only show folders and files from NTFS drive D:
and hide folders and files from NTFS drives C:, I:, J:.

Instead, the status line shows the total number of folders and files of all indexed drives (C:,D:,I:,J:).
I have the same unexpected result when I call the macro and enter in the search box: cij: and press <enter> (macro does not work).

With version 1.4.1.1007 (x64) this filter and the macro works perfectly.

I have a total of 50 filters, but only the filters that contain file exclusions, e.g. !<D:|I:|J:> - this corresponds to: !fsi: -
do not work. --> Folders and files from NTFS drive C: are to be displayed.

When manually entering: !fsi: in the search line, however, the number of objects is immediately reduced.

c: OR d: OR i: OR j: in the search box does not work (works in 1.4.1.1007 (x64)).

I work with Windows 10 Pro (German).

PS: "Indexing properties..." seems to be frozen (1.62 TB).

[OT]
Good news:
Constantly have to "Force Rebuild" seems to be fixed! :)
I will observe this for a few days and report back there.
[OT/]
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

Thanks for the bug reports.

It sounds like the OR operator is broken.

The not operator might be disabled? The or operator might be disabled? or set to a custom command?
Could you please send me your Everything.ini in %APPDATA%\Everything:

Please check the following ini settings:
not_op (should be blank, please make sure the is not a space hiding here)
allow_exclamation_point_not (should be 1)
or_op (should be blank, please make sure the is not a space hiding here)
allow_literal_operators (0 by default, 1 if you are using literal operators, eg: OR )
PS: "Indexing properties..." seems to be frozen (1.62 TB).
Indexing properties will take a long time.

I will look into showing the currently property being indexed when hovering over the status bar with the cursor.

For now, could you please send me a Mini crash dump when Everything appears stuck.
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

I have added the current filename of the property being indexed to Tools -> Options -> Properties/Content (Top Right).
Hover over this filename with the mouse cursor for the full path and filename.

Please try the latest Everything 1.5 Alpha.

What is the type of the file Everything is getting stuck on? What properties are you indexing?
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

I have sent you an email with settings and pictures.
Thanks for your support!
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

Received, thank you.
I am looking into the issue.
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

Thanks for the filters.csv.

You have a macro with no name, it is just: <search>
This is causing Everything to treat : as one of your macros.

Please try the latest Everything 1.5 Alpha.

Everything will no longer use macros with no name in version 1.5.0.1241a.

I'm still looking into the "Indexing properties..." issue.

Have you enabled 'index content' under Tools -> Options -> Content?
This is quite likely causing the startup and shutdown issues you describe.. sounds like Everything is getting stuck indexing content.. Is there a filename shown in Tools -> Options -> Content at the top right?
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

void wrote: Sun Mar 14, 2021 12:15 pm Have you enable index content under Tools -> Options -> Content?
This is quite likely causing the startup and shutdown issues you describe.. sounds like Everything is getting stuck indexing content..
Is there a filename shown in Tools -> Options -> Content at the top right?
Yes, I mistakenly entered the following: D: (in order to perform a containment for drive D: only).
When I try to switch off the content indexing completely, Everything hangs at the moment.

I'll try to install the new version and get back to you later.
Thank you!
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

2void
With version 1.5.0.1241a (x64) and [x] Index file content | Include only folders: blank
everything works for me now that I had problems with before in the themes registered above.
I.e. even with file content indexing switched on, I can work fluently (filter application, search line)!
Thank you! :)

The following would still be desirable for me:
[x] Index file content | Include only folders: ... -> I would like to restrict the file contents - indexing only to drive D:
Did I perhaps miss an option?

Filter:
I could still find the following difference between version 1007 (x64) and version 1.5.0.1241a (x64):
(I changed my shortcut from CTRL+Y to ALT+Y for filter: Everything).

Code: Select all

1007: 		Search box: cij:  (macro) .... Filter: Everything (ALT+Y) --> press ALT+Y --> Restore the default setting
		Result: Search box is emptied; CASE, WHOLE WORD, PATH, DIACRITICS, REGEX in the statusbar is removed!
		
1.5.0.1241a	Search box: cij:  (macro) .... Filter: Everything (ALT+Y) --> press ALT+Y
		Result: In Search box cij: is shown further; CASE, WHOLE WORD, PATH, DIACRITICS, REGEX in the statusbar is NOT removed!
[EDIT]
ALT+Y:
Even if you create a separate filter, e.g. with name: 'Everything ALT+Y (Default setting/Standard setting)'
with the shortcut ALT+Y, the default settings for the search are not restored.
This filter has the same settings as filter 'Everything' - only the shortcut ALT+Y was defined here.[/EDIT]

In version 1007, the default settings for the search were reset.

Can you please adapt the behaviour in version 1.5.0.1241a to version 1007, as this was very handy (-> Restore the default setting)?

With the former shortcut CTRL+Y, a new window now opens for me with the following result:

Code: Select all

Search box is emptied; CASE, WHOLE WORD, PATH, DIACRITICS, REGEX in the statusbar is removed! --> Restore the default setting
This is the same result as with version 1007 (x64) - only with an additional window.

Thank you!

___________________________________________________
Windows 10 Pro (x64) Version 20H2 (OS build 19042.867)
'Everything' 1.5.0.1241a (x64) | Portable on Systemdrive C:
'Everything' 1.4.1.1007 (x64)  | Portable on Systemdrive C:
Intel(R) Core(TM) i7-4770 CPU @ 3.4OGHz, 16 GB RAM
Last edited by tuska on Sun Mar 14, 2021 6:38 pm, edited 1 time in total.
NotNull
Posts: 5317
Joined: Wed May 24, 2017 9:22 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by NotNull »

tuska wrote: Sun Mar 14, 2021 2:52 pm The following would still be desirable for me:
[x] Index file content | Include only folders: ... -> I would like to restrict the file contents - indexing only to drive D:
Did I perhaps miss an option?
Perhaps I misunderstood ...

When you set Include only folders = D:\ , it will index the content of all filetypes specified by Include only files: on that D:-drive.


So, with
Include only folders = D:\
- and -
Include only files = *.txt

D:\some folder\important.txt will be content indexed.


Maybe the text should be changed from Include only folders: to Only in folders: ?
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

2NotNull
This is how I originally saw it too.

The indexed drives C:, I:, J: should be excluded from the indexed file content search.
However, I was unsure because there were problems with this and therefore removed the drive letter -> D: there again.

Unfortunately, it is not clear (for me) from the field name and the tooltip that you can perhaps also use drives here.

But there is still this statement...
void wrote: Sun Mar 14, 2021 12:15 pm I'm still looking into the "Indexing properties..." issue.

Have you enabled 'index content' under Tools -> Options -> Content?
This is quite likely causing the startup and shutdown issues you describe..
sounds like Everything is getting stuck indexing content..
Is there a filename shown in Tools -> Options -> Content at the top right?
Let's just wait...
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

Setting Including only folders to D:\ should include ALL folders on your D: drive:

(Subfolders are included)
-I've updated the tooltip for the next update to include a drive example.
Filter:
I could still find the following difference between version 1007 (x64) and version 1.5.0.1241a (x64):
(I changed my shortcut from CTRL+Y to ALT+Y for filter: Everything).

Code: Select all

1007: Search box: cij: (macro) .... Filter: Everything (ALT+Y) --> press ALT+Y --> Restore the default setting
Result: Search box is emptied; CASE, WHOLE WORD, PATH, DIACRITICS, REGEX in the statusbar is removed!

1.5.0.1241a Search box: cij: (macro) .... Filter: Everything (ALT+Y) --> press ALT+Y
Result: In Search box cij: is shown further; CASE, WHOLE WORD, PATH, DIACRITICS, REGEX in the statusbar is NOT removed!
Looks like you have multiple Everything filters which is confusing Everything with Alt + Y
Could you please remove the duplicated Everything filter from Search -> Organize Filters.
Does the issue persist?
This might be a bookmark conflict? Do you have any bookmarks with the Alt + Y shortcut?
I've made a note to fix this duplicated Everything filter issue.
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

2void
Thank you for the addition of the tooltip (Example: ... E:\) in the field "Include only folders:".

Could one perhaps have added an addition to the tooltip in the "Exclude folders:" field as well?
Does this really only apply to folders or also to drives?
-------------------------

Brief summary of my registered open points:
I have sent you an email with the details on 15.3.2021.

- Content indexing: A PC cold start solved the problems mentioned regarding file content search.
- Filter/Shortcut: Please see below...
  1. In version 1.4.1.1007 I defined a bookmark "Default..." with shortcut "CTRL-Y" with the following setting:
    [✓] Remember filter: Everything
    Reason:
    The shortcut CTRL-Y to the filter "Everything", does call up the filter "Everything",
    but can NOT remove the following entries in the status bar:
    CASE, WHOLE WORD, PATH, DIACRITICS, REGEX and/or the content of the search line.
     
    The bookmark with shortcut CTRL-Y also calls up the filter "Everything",
    but removes the entries in the status bar and/or in the search bar -> Restore the DEFAULT setting!
     
  2. In the new version, now 1.5.0.1242a, there were problems with the shortcut CTRL-Y,
    because this key combination is already reserved for Edit | Redo, so I tried to use
    the shortcut ALT-Y for the filter instead of the bookmark(!).
     
    The bookmark ALT-Y can remove the following entries in the status bar:
    CASE, WHOLE WORD, PATH, DIACRITICS, REGEX and/or the content of the search line. -> Restore the DEFAULT setting!
    Edit Bookmark: Field "Search:" Custom hast to be set ... leave the field to the right empty!
     
    (CTRL-Y also had the pleasant side effect of opening a new window with the DEFAULT settings opened...
    --> for this function I now use the shortcut CTRL+ALT+Y ... Edit Bookmark: Field "Search:" (No change) has to be set).
My Conclusion:
A bookmark with a shortcut can set the filter "Everything" to "DEFAULT".

This solves all of my registered problems (content indexing, filter, shortcut) --> I just have one new question above.

Thank you!

EDIT:
Interesting shortcut "combination(s)":

Code: Select all

Bookmark: ALT+Y (Restore the DEFAULT setting of Filter "Everything")
Filter:   ALT+OEM 102 (e.g. File exclusions:  !<C:|I:|J:>)
--------------------------------------------------------------------
Result:   Press the ALT + ><| - key (=left of "Y" key) several times
          to switch between Filter 'Everything' and
          Filter 'File exclusions: !<C:|I:|J:>'
	  (here a German keyboard layout)
Hint:
Version 1.5.0.1243a (x64) has overwritten the bookmark setting (version 1.5.0.1242a).
The following setting is therefore required again:
Edit Bookmark: Field "Search:" --> Custom <-- hast to be set ... leave the field to the right empty!
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

tuska wrote: Mon Mar 15, 2021 4:26 pm 2void
Thank you for the addition of the tooltip (Example: ... E:\) in the field "Include only folders:".

Could one perhaps have added an addition to the tooltip in the "Exclude folders:" field as well?
Does this really only apply to folders or also to drives?
Could I please get some more information on this?
(Content: -> [x] Index file content -> Exclude folders:)

Thanks!
void
Developer
Posts: 15623
Joined: Fri Oct 16, 2009 11:31 pm

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by void »

Yes, you can exclude drives in exclude folders.

Exclude folders - excluding a drive example:
c:\windows;c:\program files;e:\

I have updated the tooltip in version 1.5.0.1244a to give a drive example.
tuska
Posts: 954
Joined: Thu Jul 13, 2017 9:14 am

Re: [1.5.0.1238a (x64) portable] Filter (with '!') shows no effect

Post by tuska »

void wrote: Wed Mar 17, 2021 11:57 am Yes, you can exclude drives in exclude folders.

Exclude folders - excluding a drive example:
c:\windows;c:\program files;e:\

I have updated the tooltip in version 1.5.0.1244a to give a drive example.
Thank you for the addition of: E:\ drive as an example in the tooltip
to -> "Content: -> [✓] Index file content -> field: 'Exclude folders:' ".
Post Reply