Page 1 of 1

1.4.1.877: Freezing on launch due to Unicode symbols in folder names

Posted: Sun Jul 02, 2017 11:31 pm
by choin
I have several HDD added to database. During the first launch, I've set drives I need in settings, then I exited Everything to let it save the database. On second launch, it shows blank window, I see the following messages in status bar:
Loading database
Updating database
x xxx xxx objects (amount of files on my drives)

And nothing else - the window remains blank. In Task Manager I see that it uses 0% CPU, 0% HDD. It's marked "Not responding". I can't click anywhere on Everything window. I have to end its process and try running it again. Sometimes it loads fine, but most of times not.

I've been trying a few things and found out the following:
I have a couple of folders named " ". Not a blank space, but ideographic space (U+3000, E38080 in hex). I've noticed that when default sort is set by Name column, these folders appear very first, Everything tends to freeze when launching like this. If I rename those folders to anything simple and non-Unicode, there is no freeze. Or if I change the sort order or sort column, so they don't appear first, there is also no freeze.

I hope this can be fixed at some point.

Re: 1.4.1.877: Freezing on launch due to Unicode symbols in folder names

Posted: Sun Jul 02, 2017 11:57 pm
by void
Could you please send some debug output:
  • In Everything, type in the following search and press ENTER:
    /debug=1
  • Exit everything (right click the Everything system tray icon and click Exit)
  • Restart Everything.
  • What is displayed in the debug console after Everything has frozen?
Please send debug output to support@voidtools.com

Re: 1.4.1.877: Freezing on launch due to Unicode symbols in folder names

Posted: Mon Jul 03, 2017 4:34 pm
by choin
Sent.