Preview Winword 2002 & 2007 (changed link)

Found a bug in "Everything"? report it here
Post Reply
Marti-Every
Posts: 27
Joined: Thu Aug 01, 2013 4:54 pm

Preview Winword 2002 & 2007 (changed link)

Post by Marti-Every » Sun Oct 25, 2015 12:17 pm

I have a problem with the preview with .doc Documents :(
I have installed Winword 2002 and Winword 2007, the link / double-click in explorer is to open the doc-documents with Word 2002 (don't like ribbons). In the preview with everything, the documents are shown :) , but after this, the link is to Word 2007 :( .

The opening of Word 2002 is attached by a installation popup of Windword. The association of Word 2002 is lost and only after a reboot it works in my right way. I think it is not directly a problem of EVERYTHING, but of Microsoft :x . It was difficult to install Word 2002 and 2007 in Windows 7 64bit.
I have added in the registry:
HKEY_CURRENT_USER\Software\Microsoft\Office\12.0\Word\Options: DWORD „NoReReg“ 1

Is there a trick to associate .doc permanently with Word 2002 ?
Or can there be a option in everything like: 8-)
Do not associate preview: *.doc; *.xyz

void
Site Admin
Posts: 6062
Joined: Fri Oct 16, 2009 11:31 pm

Re: Preview Winword 2002 & 2007 (changed link)

Post by void » Tue Oct 27, 2015 5:10 am

In the preview with everything, the documents are shown :) , but after this, the link is to Word 2007 :( .
If I understand correctly, if the preview pane is not shown, Everything will open the word document with word 2002?
Only when the preview pane is shown, Everything opens word documents with word 2007?
Is there a trick to associate .doc permanently with Word 2002 ?
Everything will open the doc file with the default verb specified in the registry.

Have a look under HKEY_CLASSES_ROOT\.doc and take note of the (Default) value, it will be something like:
Word.Document.8

Now, under HKEY_CLASSES_ROOT\Word.Document.8\shell
(where Word.Document.8 is the default value in .doc above)
The (Default) value here will specify the default verb. It should be open.

The command that Everything should now call is under:
HKEY_CLASSES_ROOT\Word.Document.8\shell\open\command
(where open is the default verb specified above)

You will also find the preview handler identifier under:
HKEY_CLASSES_ROOT\Word.Document.8\shellex\{8895b1c6-b41f-4c1c-a562-0d564250836f}

Unfortunately, changing this will change the preview handler for doc files system wide.
There's currently no option to change this just for Everything.

Marti-Every
Posts: 27
Joined: Thu Aug 01, 2013 4:54 pm

Re: Preview Winword 2002 & 2007 (changed link)

Post by Marti-Every » Tue Oct 27, 2015 1:05 pm

The preview pane is correctly shown :) , but later after the first preview the double-click in the file explorer is no more associated with Word 2002 as standard. Now .doc are opened with word 2007 :?
In my settings normaly .doc ist opened with word 2002 and .docx is with 2007, that's the way I want to have it. After a reboot it is normaly standard, but a new .doc in the preview pane, then all documents are opened again with word 2007.

I don't have this entry:
Marti-Every wrote:You will also find the preview handler identifier under:
HKEY_CLASSES_ROOT\Word.Document.8\shellex\{8895b1c6-b41f-4c1c-a562-0d564250836f}

Can you tell me the syntax to make a .reg file :?:

The others HKEY_CLASSES_ROOT\Word.Document.8\shell
with open\command and edit\command
have the "C:\Program Files (x86)\Microsoft Office\Office10\WINWORD.EXE" /n /dde (Winword 2002)
I don't have used the preview for Word, because in the explorer it is not shown in left preview corner at the bottom. The preview window at the right side I do not use (but it is working), because it is to big. I think I have the same problems when a preview in this right window i have used.

Is there a way to disable the Word-preview completly :?:

void
Site Admin
Posts: 6062
Joined: Fri Oct 16, 2009 11:31 pm

Re: Preview Winword 2002 & 2007 (changed link)

Post by void » Wed Oct 28, 2015 9:29 am

Can you tell me the syntax to make a .reg file :?:
Deleting and Renaming Registry Keys and Values with a .reg file

Note: This destroys the key, making it difficult to restore if you ever wanted to see the 2007 preview again.

Code: Select all

Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\.doc\shellex\{8895b1c6-b41f-4c1c-a562-0d564250836f}]
I would recommend editing the registry directly:
Is there a way to disable the Word-preview completly :?:
Rename the following key:

Code: Select all

HKEY_CLASSES_ROOT\.doc\shellex\{8895b1c6-b41f-4c1c-a562-0d564250836f}
to:

Code: Select all

HKEY_CLASSES_ROOT\.doc\shellex\_{8895b1c6-b41f-4c1c-a562-0d564250836f}

Marti-Every
Posts: 27
Joined: Thu Aug 01, 2013 4:54 pm

Re: Preview Winword 2002 & 2007 (changed link)

Post by Marti-Every » Wed Oct 28, 2015 3:14 pm

void wrote:Rename the following key:

Code: Select all
HKEY_CLASSES_ROOT\.doc\shellex\{8895b1c6-b41f-4c1c-a562-0d564250836f}

to:

Code: Select all
HKEY_CLASSES_ROOT\.doc\shellex\_{8895b1c6-b41f-4c1c-a562-0d564250836f}
GREAT, this works fine for me, no more preview for *.doc :)
If have changed also the key for \.docx\shellex\.., so no more preview for *.docx :)

Now, my .doc ist opened with word 2002 and .docx is with 2007, that's the way I want to have it. 8-)
All others previews are working correctly, the preview ist a great Upgrade 8-) :D :)

Post Reply