default editor for txt files

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
mehl
Posts: 7
Joined: Tue Aug 04, 2020 4:39 am

default editor for txt files

Post by mehl » Tue Aug 04, 2020 7:01 am

Hello --
The recent update wiped out my preference of Textpad for .txt files (it is my Win 10 "default app by file type")
Can someone remind me how to set my preference again?

Thanks for any help,

Stephen Mehl

tuska
Posts: 279
Joined: Thu Jul 13, 2017 9:14 am

Re: default editor for txt files

Post by tuska » Tue Aug 04, 2020 10:48 am

Hello,

press Windows key + i -> Apps -> Select default apps by file type -> press the '+' Select standard key ...
(translated from german language)

NotNull
Posts: 2693
Joined: Wed May 24, 2017 9:22 pm

Re: default editor for txt files

Post by NotNull » Tue Aug 04, 2020 5:04 pm

... and if that didn't help: you might be running Everything as administrator instead of running as a regular user (the default program is a per-user setting)

In that case:
- Enable Everything Service
- Disable Run as administrator

Both settings can e found under Menu:Tools > Options > General

mehl
Posts: 7
Joined: Tue Aug 04, 2020 4:39 am

Re: default editor for txt files

Post by mehl » Thu Aug 06, 2020 10:58 pm

tuska and NotNull --

Thank you.
.txt files were already set to open with TextPad.

I enabled Everything Service and Disabled Run as administrator.

It now works the way I want.

mehl
Posts: 7
Joined: Tue Aug 04, 2020 4:39 am

Re: default editor for txt files

Post by mehl » Wed Nov 25, 2020 5:44 am

Help is needed again.

Something happened that changed the app that opens when a *.txt file is double-clicked to
Notepad.

Double-clicking a *.txt file in Explorer correctly opens in in TextPad.

Can anyone suggest other places to look in Everything or Windows or somewhere else to set Everything to open a *.txt file with TextPad?

Thanks in advance for any help.

Stephen Mehl

NotNull
Posts: 2693
Joined: Wed May 24, 2017 9:22 pm

Re: default editor for txt files

Post by NotNull » Wed Nov 25, 2020 3:54 pm

Maybe you start Everything with a shortcut that forces Everything to start as administrator.

First steps to check if you are running as admnistrator:
  • In Everything's search bar, type
    /debug
    and press ENTER
    A new "DOS window" will open. This is Everything's debug console
  • Press keyboard shortcut CTRL+M in this window
  • Scroll to the top
    Here you can find lines similar to these:

    Code: Select all

    Everything
    Version 1.4.1.988 (x64)
    Windows NT 6.2
    Processors 2
    IsAdmin 0
    AppData 0
    Service 1
    cmdline "C:\Tools\Everything\Everything.exe"
    
  • Post your lines here.
    ( Especially the IsAdmin line is important; If you are somehow running as administrator, that line will read IsAdmin 1
  • Press escape in the debug window
  • Go back to Everything
  • Close the debug window:
    In Everything's search bar, type
    /debug
    and press ENTER

therube
Posts: 2856
Joined: Thu Sep 03, 2009 6:48 pm

Re: default editor for txt files

Post by therube » Wed Nov 25, 2020 4:05 pm

Double check that you are still using the Everything Service & not running "As Administrator".

mehl
Posts: 7
Joined: Tue Aug 04, 2020 4:39 am

Re: default editor for txt files

Post by mehl » Thu Nov 26, 2020 2:03 am

Hello NotNull and therube --

Thanks for responding.

My first lines in /debug are

Everything
Version 1.4.1.992 (x64)
Windows NT 6.2
Processors 4
IsAdmin 1
AppData 1
Service 1
cmdline "C:\Program Files\Everything\Everything.exe" -isrunas -startup
WM_ACTIVATE 0000000000000000 0000000000000000, lastfocus 00000000001a1b80, current focus 00000000001a1b80
update index C:


IsAdmin, AppData and cmdline don't match your example.

In Everything Options
- Run as administrator is not checked
- Store settings and data in %APPDATA%\Everything is checked
- are -isrunas and -startup set wrong?

In Windows > Services > Services (Local)
Everything has no description; Status is "Running", Startup Type is "Automatic", Log On As is "Local System"

Thanks in advance for your continued help.

Stephen Mehl

mehl
Posts: 7
Joined: Tue Aug 04, 2020 4:39 am

Re: default editor for txt files

Post by mehl » Thu Nov 26, 2020 4:56 am

After doing nothing except the commands you suggested ...
it works now.

Thank you

Stephen

NotNull
Posts: 2693
Joined: Wed May 24, 2017 9:22 pm

Re: default editor for txt files

Post by NotNull » Thu Nov 26, 2020 10:35 pm

Your IsAdmin 1 tells us that you are indeed running as administrator.
That is caused by the -isrunas in cmdline "C:\Program Files\Everything\Everything.exe" -isrunas -startup

I'm a bit surprised that all is OK now.
If you reopen the debug console, does it now tell you IsAdmin 0 ?

Post Reply