Page 1 of 1

First run of Everything takes 5mins scanning C:

Posted: Tue Mar 09, 2010 11:44 am
by Rochey
Hi all,

For some reason, recently, Everything has been hanging and slow. To go hand in hand with this I have been tidying my laptop (removing old files/folders, un-installing software, defragging etc.), so the reason Everything is slow may be to do with something I've done.

What happens is, because I am experiencing the "Monitor changes" bug, I am deleting the db to get Everything to recreate it. But to recreate the db it takes 5mins (bottom left shows "Scanning Local Disk (C:)"). After it has recreated the db I close it down cleanly to save the db and then Everything is quick again.

Has anybody experienced this? Is there anything I can check on my laptop?

I have run a chkdsk on my C: drive and all is ok. I have all the default settings on in the "Volumes" tab in Everything. I have run Everything in -debug mode and it just says:

WM_ACTIVATE 00000001 00000000
search edit focus 2
db::load
db::destroy
load db...
db::destroy
db::create
db::destroy
WM_ACTIVATE 00000000 00000000

I am running XP sp3 and version "Everything-1.2.1.452a.exe" ( I have also tried "Everything-1.2.1.451a.exe").

Regards,

Rochey

Re: First run of Everything takes 5mins scanning C:

Posted: Wed Mar 10, 2010 3:13 am
by void
Please make sure your drives are in DMA transfer mode.

Please see Slow indexing for more information.

Re: First run of Everything takes 5mins scanning C:

Posted: Thu Mar 11, 2010 8:33 am
by Rochey
Hi Void,

Thanks for responding.
I did find that "Slow indexing" post when I was trying to resolve the issue myself.
I have double checked the DMA settings and mine shows for Device 0;

Device type: Auto Detection (greyed out)
Transfer Mode: DMA if available (other option is PIO Only)
Current Transfer Mode: Multi-Word DMA Mode 2

But even with the above settings it still takes 5mins or so to scan first time.
Any other things that I can check?

Rochey

Re: First run of Everything takes 5mins scanning C:

Posted: Sat Mar 13, 2010 9:46 am
by void
You may need to enable Ultra DMA Mode 5 from your BIOS.

Re: First run of Everything takes 5mins scanning C:

Posted: Thu Jun 24, 2010 3:44 pm
by VadiMGP
I have the similar problem.
My physical disk is devided into two logical volumes (e: and f:)
Volume E: contains 20000 files and volume F: contains 30000 files.
Scanning of volume E: takes about 1-2 seconds while scanning of volume F: takes 3-4 minutes!
Chkdsk shows no errors on volumes and Device Manages show "Ultra DMA Mode 4" for this device.

Any idea?

Re: First run of Everything takes 5mins scanning C:

Posted: Fri Jun 25, 2010 2:48 am
by void
Please try running a Disk Defragmenter Analysis report.

To run a Disk Defragmenter Analysis report:
  • From My Computer, right click your F: volume and select Properties.
  • From the Tools tab, click Defragment Now....
  • Select your F: drive in the volume list.
  • Click Analyse.
  • Wait for the Disk Deframenter to Analyse the volume...
  • Click View Report.
In the Volume information, how many Total MFT fragments are there?
Any more than 1 will severly reduce the performance of "Everything" indexing this volume.

Please note, you can not defragment the MFT with the Windows Disk Defragmenter.

Re: First run of Everything takes 5mins scanning C:

Posted: Fri Jun 25, 2010 10:44 am
by VadiMGP
This is a result of analyzer
Master File Table (MFT) fragmentation
Total MFT size = 5.52 GB
MFT record count = 32 085
Percent MFT in use = 0 %
Total MFT fragments = 3
Yes, MFT fragmented, but I don't think that it is a problem because MFT of all other drives also fragmented.

But I noticed that this MFT is abnormally huge - 5.5 GB! I have no idea how it happens but I think this is a problem. Even on my external 1Tb disk MFT size is 100Mb.
Do you know any way to reduce MFT?

Re: First run of Everything takes 5mins scanning C:

Posted: Fri Jun 25, 2010 11:42 am
by VadiMGP
Well, the problem is gone after volume reformatting.
Now MFT still fragmented, but size is 10 Mb and indexing takes less then 1 second with the same 30000 files.

Thanks for tip!

BTW. Is there any way to enforce Everything to rebuild index for specific volume only?

Re: First run of Everything takes 5mins scanning C:

Posted: Sun Jun 27, 2010 10:10 pm
by daspud
From memory: In Options there is a choice to include or exclude a volume. You exclude the volume and apply that then include it and it should rescan.

Never trust memory!

Options, Volumes, select the volume you want to reindex, UNcheck include in database, APPLY, check Include in data base and apply.

Reindexed!