Firewall settings for ETP and network share

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
daydreamer
Posts: 2
Joined: Thu Sep 13, 2018 2:05 pm

Firewall settings for ETP and network share

Post by daydreamer » Thu Sep 13, 2018 5:20 pm

I love Everything and I have a shared network drive on another Windows 10 computer that I currently log into using Remote Desktop in order to search it for files. Today I tried to get my client PC version of Everything to utilise this host program using ETP which is a brilliant feature. Offering the indexing done using NTFS on the host PC and even matching the way I've mapped it to a drive letter is genius.

So, I managed to get it to work but only when the firewall was disabled for the Public network. I tried configuring a rule to bypass the firewall using the program Everything.exe, the port (which I changed from 21) and the service (I have Everything running as a service on the host PC).

Nothing works.

It works perfectly when Windows firewall is completely disabled but obviously I can't leave it this way. I'm so close to having it work as I want! I realise I can add it as a Indexed Folder but this is slow and I want to utilise Everything's lightning-fast indexing. Any ideas?

NotNull
Posts: 1357
Joined: Wed May 24, 2017 9:22 pm

Re: Firewall settings for ETP and network share

Post by NotNull » Thu Sep 13, 2018 6:24 pm

Are you sure there is no other firewall rule blocking port 21 (FTP)?

Try it by using port 2121 for Everything. Does that work?

Othr suggestion: try private network (or whatever it is called) instead of public network.

void
Site Admin
Posts: 4813
Joined: Fri Oct 16, 2009 11:31 pm

Re: Firewall settings for ETP and network share

Post by void » Fri Sep 14, 2018 2:25 pm

In Windows Firewall, please make sure Everything is checked and Public is checked for Everything.


daydreamer
Posts: 2
Joined: Thu Sep 13, 2018 2:05 pm

Re: Firewall settings for ETP and network share

Post by daydreamer » Mon Sep 17, 2018 11:09 am

Thanks void! That was it :)

Post Reply