Double Results

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
ramzi
Posts: 5
Joined: Wed Aug 12, 2015 8:59 am

Double Results

Post by ramzi » Mon Dec 12, 2016 10:06 am

When I enter a search word, I get two lines for every result. When I then rename or delete, the change occurs to both. I have gone through Options to see what could have caused this and I can't see anything. It must be there though so perhaps someone on this forum has a solution.

btw, I wrote Support about two weeks ago and got no reply.

void
Site Admin
Posts: 6094
Joined: Fri Oct 16, 2009 11:31 pm

Re: Double Results

Post by void » Mon Dec 12, 2016 10:13 am

Please try removing any folder indexes that may have already been included as NTFS indexes:
  • In Everything, from the Tools menu, click Options.
  • Click the Folders tab.
  • Select the folder index that is showing up twice in the results.
  • Click Remove.
  • Click OK.
Sorry, I must have missed your email.

TTTTII
Posts: 11
Joined: Mon Aug 08, 2016 11:58 pm

Re: Double Results

Post by TTTTII » Mon Dec 12, 2016 9:01 pm

I may as well post this question/suggestion here as anywhere:

Is there any way to return only unique values for a search? For example, a child: search for folders will often include duplicates.

Though, I suppose putting the results in a good text editor and using this regex to remove duplicate, consecutive lines is good enough:

^(.*)(\r?\n\1)+$

Replace with:
\1

By the way, an exceedingly useful search is:

child: regex:[^\x00-\x7f]

which will find folders with non-ascii characters in child files.

void
Site Admin
Posts: 6094
Joined: Fri Oct 16, 2009 11:31 pm

Re: Double Results

Post by void » Tue Dec 13, 2016 7:33 am

Is there any way to return only unique values for a search? For example, a child: search for folders will often include duplicates.
Sounds like you still have duplicated volumes in your index as they should only appear once.
Please try removing all folder indexes:
  • In Everything, from the Tools menu, click Options.
  • Click the Folders tab.
  • For each folder:
    • Click Remove.
  • Click OK.

ramzi
Posts: 5
Joined: Wed Aug 12, 2015 8:59 am

Re: Double Results

Post by ramzi » Tue Dec 13, 2016 10:55 am

void wrote:Please try removing any folder indexes that may have already been included as NTFS indexes:
  • In Everything, from the Tools menu, click Options.
  • Click the Folders tab.
  • Select the folder index that is showing up twice in the results.
  • Click Remove.
  • Click OK.
Sorry, I must have missed your email.
--------------------

OK thanks David,all good now.

faroe2k9
Posts: 12
Joined: Fri May 06, 2016 10:34 am

Re: Double Results

Post by faroe2k9 » Sun Dec 18, 2016 4:13 pm

TTTTII wrote:I may as well post this question/suggestion here as anywhere:
...
By the way, an exceedingly useful search is:
child: regex:[^\x00-\x7f]

which will find folders with non-ascii characters in child files.
Thank you so much for this expression. I have bookmarked it with the name polar: - so when i use the search: polar:825
it finds the folder 825

This program is SO awesome!

Post Reply