Page 1 of 1

Everything v1.2.1.451a as a service on Windows 7

Posted: Sat Dec 11, 2010 4:00 am
by deepdvd
I'm running Everything version 1.2.1.451a as a service on Windows 7 64bit (Everything.exe -install_service), but it doesn't seem to be working correctly. When I log in, I don't have the GUI available (i.e. It doesn't appear in the system tray)

Because of this, I also have to have Everything run at login to access the GUI search window, so essentially it has to be running twice. I don't prefer this, but it doesn't bother me much. (I know you're normally supposed to disable it from starting at login)

Both instances use the same settings which include starting the HTTP server on startup. It's already using port 80 for the service (I want this), and I can't prevent the HTTP server from attempting to start twice. Because of this, I get the following popup every time I log in.
Image

Anyone have ideas? I log in with an Administrator account, so that's not an issue for me. Essentially, I don't want my kids accessing my computer, so I have to enable a password to log in, but I still want to access Everything remotely with the HTTP server, so I enabled the service.

I tried this on windows XP, and it works the way I want it to by showing the Everything icon for the user who logs in and only has to have the service running.

How can I get it to work correctly in Windows 7 (64bit) ? If I have to have two intances running (user and service), that's not a huge deal, but I would need them to have different settings, so it doesn't attempt to start the HTTP server on the user process.

Could it be that I need to edit the "service parameters" option in the .ini settings file?

Thanks,
David

Re: Everything v1.2.1.451a as a service on Windows 7

Posted: Mon Dec 13, 2010 6:30 pm
by deepdvd
I figured out what I needed to do by looking at the command line options on the Everything Wiki page: http://support.voidtools.com/everything ... ions#-host

All I had to do was modify the startup line in the registry to use a modified config file (e.g. EverythingUser.ini) that doesn't start the HTTP server (because it's already running from the service instance)

"C:\Program Files (x86)\Everything\Everything.exe" -startup -config EverythingUser.ini

I still wish I could use the service instance on any admin user logged in with Windows 7