[SOLVED] Add properties - automatically sorting - incorrect allocations of settings

Discussion related to "Everything" 1.5 Alpha.
Post Reply
tuska
Posts: 368
Joined: Thu Jul 13, 2017 9:14 am

[SOLVED] Add properties - automatically sorting - incorrect allocations of settings

Post by tuska » Sun May 16, 2021 4:34 pm

Hi,

Add properties:

Code: Select all

1. Tags			*.doc;*.docx;*.dotx;*.pdf;*.xls;*.xlsx;*.xlsm;*.xlt;*.xltx;*.xltm;*.ppt;*.pptx
2. Comments		*.doc;*.docx;*.dotx;*.pdf;*.xls;*.xlsx;*.xlsm;*.xlt;*.xltx;*.xltm;*.ppt;*.pptx
3. Aufnahmedatum	D:\Bilder\**.jpg	(corresponds to "Date taken")
In the menu, the entries appear unsorted:
1. Comment
2. Aufnahmedatum ("Date taken")
3. Tags

Click on Button "Apply".
Now the names of the properties were sorted *automatically* in ascending order, but the settings were not sorted as well.

This leads to incorrect assignments of settings - only in the settings view!
In the columns the correct values are displayed and in queries I also get correct results!

Please check.
Thank you.

________________________________________________
Windows 10 Pro (x64) Version 20H2 (OS build 19042.985)
'Everything' 1.5.0.1259a (x64)
Last edited by tuska on Fri May 21, 2021 10:48 am, edited 1 time in total.

void
Site Admin
Posts: 6880
Joined: Fri Oct 16, 2009 11:31 pm

Re: Add properties - automatically sorting - incorrect allocations of settings

Post by void » Mon May 17, 2021 7:25 am

Thanks for the bug report tuska,

Everything is indeed sorting property-system properties incorrectly.

I am working on a fix..

void
Site Admin
Posts: 6880
Joined: Fri Oct 16, 2009 11:31 pm

Re: Add properties - automatically sorting - incorrect allocations of settings

Post by void » Fri May 21, 2021 5:43 am

Everything 1.5.0.1260a fixes an issue with sorting Windows Property-System properties.

tuska
Posts: 368
Joined: Thu Jul 13, 2017 9:14 am

Re: Add properties - automatically sorting - incorrect allocations of settings

Post by tuska » Fri May 21, 2021 9:35 am

2void
This is fixed in Everything 1.5.0.1260a - tested with x64 version.

I was very pleased to see that after an indexing ("Indexing properties:")
the settings under "Properties" were already automatically corrected!   :)

Thank you very much!

Post Reply