Search and run history aren't saving.

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
sapphi10489
Posts: 4
Joined: Fri Jan 01, 2021 7:56 am

Search and run history aren't saving.

Post by sapphi10489 » Fri Jan 01, 2021 8:11 am

I'm on 1.4 and no matter if its in program files or appdata.It will just stay when it was lasted updated which is november. I have the latest version.

void
Site Admin
Posts: 6067
Joined: Fri Oct 16, 2009 11:31 pm

Re: Search and run history aren't saving.

Post by void » Fri Jan 01, 2021 8:17 am

Please make a backup of your %APPDATA%\Everything folder.

Everything normally saves your history in %APPDATA%\Everything.

Please make sure Everything is running as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Store settings and data in %APPDATA%\Everything
  • Uncheck Run as administrator.
  • Check Everything Service. (Please make sure this is tick-checked and not square-checked)
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.
Is the disk full?

Please make sure there is no .tmp files in your %APPDATA%\Everything folder.

sapphi10489
Posts: 4
Joined: Fri Jan 01, 2021 7:56 am

Re: Search and run history aren't saving.

Post by sapphi10489 » Fri Jan 01, 2021 8:33 am

No,the disk isn't full.I had it running as a service. I even reinstalled it a few times and it still isn't working.The .db files also are stuck on older last modified dates.

void
Site Admin
Posts: 6067
Joined: Fri Oct 16, 2009 11:31 pm

Re: Search and run history aren't saving.

Post by void » Fri Jan 01, 2021 8:51 am

Please make sure you only have one version of Everything installed.
For example, if you have the x86 and the x64 version installed, please uninstall one.

Everything only writes the database to disk when you exit Everything.

Search and Run History csv files should update on disk after each change is made from Everything.

Could you please send some debug output?
  • In Everything, type in the following search and press ENTER:
    /debuglog
  • Open a random file from Everything to add it to your run history.
  • Please send your %TEMP%\Everything Debug Log.txt
  • In Everything, type in the following search and press ENTER:
    /restart
  • This will stop debug logging (by restarting Everything) as the logs can grow very large.
Does the Everything.db update on disk after the /restart?

sapphi10489
Posts: 4
Joined: Fri Jan 01, 2021 7:56 am

Re: Search and run history aren't saving.

Post by sapphi10489 » Fri Jan 01, 2021 11:21 am

Ok,I checked and its only installed in x64 folder. Also something weird I found. Everything.db is located in the appdata/local everything folder and it isn't updating. But it looks new files were created for the everything.ini and the run/search history csv in the appdata/roaming everything folder and they're now updating.I will send debub.

void
Site Admin
Posts: 6067
Joined: Fri Oct 16, 2009 11:31 pm

Re: Search and run history aren't saving.

Post by void » Fri Jan 01, 2021 11:32 am

Thanks for the debug logs.

The logs show the Run History.csv.tmp is created and successfully renamed to Run History.csv.
Same with the Search History.csv

Is Everything saving your history now?

Perhaps there is another installation conflicting with your settings and data.
If you make a search/run history change, restart Everything, does your search/run history persist?



The Everything.db is stored in %LOCALAPPDATA%\Everything
while settings and data are stored in %APPDATA%\Everything

sapphi10489
Posts: 4
Joined: Fri Jan 01, 2021 7:56 am

Re: Search and run history aren't saving.

Post by sapphi10489 » Fri Jan 01, 2021 11:53 am

Yea,it looks like new copies were created and everything is working.I think I figured it out.I think it was linked to my backup copy of the windows partition that was on another HDD.

Post Reply