Crashed "Out-Of-The-Blue"

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 5:39 pm

Hello,
I have be using Everything for about two years now. Its been one of the most useful tools created for Windows. Never had any problems with it until ....

I copy and pasted from Windows Notepad to the command bar "ansicontent:" (no trailing data input). It started its usual processing by displaying "Querrying ..." at the bottom status bar, for about 10 seconds.

THEN this popped up:


Image

As I am posting this .... I have not closed out Everything. I'm willing to provide more technical details if a walk-thru could be feasible ....
Very unusual behavior
Anyone have an idea as to why this occurred ?
Yeah, I know this could be many 100's of different reasons on a Windows machine.
I'm quite familiar with PC tech ... so you can throw me a bone or two :D ^.^
Thanks
Curt

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 6:16 pm

Ok, just for the sake of argument, I rebooted my Windows machine to "Safe-Mode" and I tried the same thing AND the error reproduced itself again.
So, I'm sure that it has nothing to do with the software, other than Everything not having some sort of "memory limiting" coding. I'm sure that the Dev didn't have this in mind and wasn't thinking that he should code this program for specific Windows environments otherwise, this is very understandable from a Dev point of view.

Its more that likely that this machine and this version of Windows is causing this particular problem, despite not having any past problems.

Maybe I need to upgrade to Windows 10 64-bit?

I really do not want to have to do that, because I still are using 32bit programs and games that were made for Win98-Win2000-WinXP.

So for now on I will just have too NOT use that command ....

Sorry to say ....

horst.epp
Posts: 175
Joined: Fri Apr 04, 2014 3:24 pm

Re: Crashed "Out-Of-The-Blue"

Post by horst.epp » Fri Dec 21, 2018 6:22 pm

spazumnator wrote:
Fri Dec 21, 2018 6:16 pm
...
Maybe I need to upgrade to Windows 10 64-bit?
I really do not want to have to do that, because I still are using 32bit programs and games that were made for Win98-Win2000-WinXP.
So for now on I will just have too NOT use that command ....

Sorry to say ....
You hopefully don't expect any support for that zoo of outdated OSs

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 6:27 pm

horst.epp wrote:
Fri Dec 21, 2018 6:22 pm
spazumnator wrote:
Fri Dec 21, 2018 6:16 pm
...
Maybe I need to upgrade to Windows 10 64-bit?
I really do not want to have to do that, because I still are using 32bit programs and games that were made for Win98-Win2000-WinXP.
So for now on I will just have too NOT use that command ....

Sorry to say ....
You hopefully don't expect any support for that zoo of outdated OSs
Nope ... I assume the worse case scenario LMAO

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 6:46 pm

Maybe this posts' home shoulda been in "Bug report" instead of here ...

I just now thought of that .... >.>

NotNull
Posts: 1282
Joined: Wed May 24, 2017 9:22 pm

Re: Crashed "Out-Of-The-Blue"

Post by NotNull » Fri Dec 21, 2018 6:59 pm

I tested this with the same ansicontent: query and after about 15 minutes (slow system, I guess :)) I got the same error message. At that point Everything was using a very atypical 1.5 GB RAM (normally around 50MB on this system)

After clicking OK, Everything.exe closed.

( Win10 1803 ; Everything 1.4.1.895 x64 )

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 7:26 pm

NotNull wrote:
Fri Dec 21, 2018 6:59 pm
I tested this with the same ansicontent: query and after about 15 minutes (slow system, I guess :)) I got the same error message. At that point Everything was using a very atypical 1.5 GB RAM (normally around 50MB on this system)

After clicking OK, Everything.exe closed.

( Win10 1803 ; Everything 1.4.1.895 x64 )
I have Window 7 Utimate 32-bit on a Quad Core AMD Phenom 9850 Processor 2.5Ghz
Maxed out memory 8GB ... but I multiboot with Ubunto 14 not VirtualBox

I know that Windows is using only 4G of that memory too ...

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 7:36 pm

The only other thing that I can eliminate, is the fact that I'm using an older Everything.exe version ... I haven't installed the latest yet ...

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 7:41 pm

spazumnator wrote:
Fri Dec 21, 2018 7:36 pm
The only other thing that I can eliminate, is the fact that I'm using an older Everything.exe version ... I haven't installed the latest yet ...
Ok i've eliminated that problem ... I thought I was using an older version but copy/paste from ABOUT: Version 1.4.1.895 (x86)

Hmmm ....

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Fri Dec 21, 2018 7:47 pm

spazumnator wrote:
Fri Dec 21, 2018 7:41 pm
spazumnator wrote:
Fri Dec 21, 2018 7:36 pm
The only other thing that I can eliminate, is the fact that I'm using an older Everything.exe version ... I haven't installed the latest yet ...
Ok i've eliminated that problem ... I thought I was using an older version but copy/paste from ABOUT: Version 1.4.1.895 (x86)

Hmmm ....
Ok ... my mistake Version 1.4.1.895 isn't the latest version ... 1.4.1.924 is ...

I'll install the new version and see waht happens

NotNull
Posts: 1282
Joined: Wed May 24, 2017 9:22 pm

Re: Crashed "Out-Of-The-Blue"

Post by NotNull » Fri Dec 21, 2018 7:58 pm

I think it's a bug.

In a future version of Everything the handling of content: ansicontent: and the like will change. That will solve this issue too (according to my 'calculations')

But an intermediate solution would be welcome :) (like: dont accept empty values for these functions)

For now: just add the text you wanted to search for. That should work without problems :D
That turned out to be optimistic; searching for
ansicontent:text
makes Everything run out of memoryt too!

Will test further to find out if it has anything to do with very large files. ...

therube
Posts: 2263
Joined: Thu Sep 03, 2009 6:48 pm

Re: Crashed "Out-Of-The-Blue"

Post by therube » Fri Dec 21, 2018 9:08 pm

Well, I guess without any filtering (like specific directory + files), it will search through every file, for your search term, even including "".

Hmm...
Seems like even an invalid directory spec throws it for a loop.
Like I did a:

> ansicontent:therube c:/tmp/msn *.dll

But c:/tmp/msn was wrong.
It should have been, c:/tmp/sea/msn.

And with that invalid directory spec, it never finished
That's not exactly what is going on. Wrongly explained based on wrong understanding of what was happening.

_|
_v

Ah it also kind of looks like you'll want to enclose the "content:" searches in quotes.
Otherwise... not quite sure, but maybe the strings after the content: are treated as search terms?

So:

> ansicontent:"therube" c:/tmp/msn *.dll

works much better.

Or at least rearrange the search:

> c:/tmp/msn *.dll ansicontent:therube

> "ansicontent:therube" c:/tmp/msn *.dll
works much better.
That too is wrong. It simply returned no results (which was expected).

Seems, filtering should come before any content: terms.

So, > c:/tmp/msn *.dll ansicontent:therube

Maybe ;-).

void
Site Admin
Posts: 4758
Joined: Fri Oct 16, 2009 11:31 pm

Re: Crashed "Out-Of-The-Blue"

Post by void » Fri Dec 21, 2018 11:21 pm

This error occurs when Everything runs out of memory.

28010000 is the amount memory Everything tried to allocate in hex. (671,154,176 bytes)

When using content:, ansicontent: or unicodecontent: Everything will load the entire file into memory to perform the search.
To make this worse, ansicontent:/unicodecontent: must create another very large buffer to convert the contents to UTF-8 to perform the desired search.
It is this large buffer that has no sane-memory allocation limits.

Please try including size:<100mb with your ansicontent: search to limit the content search to smaller files only.

content: functions search all files. UTF-8 is assumed if no IFilter is associated with a file.
please try limiting to a specific file type, for example: *.txt

The next version of Everything will not throw this error and silently fail.

spazumnator
Posts: 11
Joined: Fri Dec 21, 2018 5:00 pm

Re: Crashed "Out-Of-The-Blue"

Post by spazumnator » Sat Dec 22, 2018 6:48 am

void wrote:
Fri Dec 21, 2018 11:21 pm
This error occurs when Everything runs out of memory.

28010000 is the amount memory tried to allocate in hex.

When using content:, ansicontent: or unicodecontent: Everything will load the entire file into memory to perform the search.
To make this worse, ansicontent:/unicodecontent: must create another very large buffer to convert the contents to UTF-8 to perform the desired search.
It is this large buffer that has no sane-memory allocation limits.

Please try including size:<100mb with your ansicontent: search to limit the content search to smaller files only.

content: functions search all files. UTF-8 is assumed if no IFilter is associated with a file.
please try limiting to a specific file type, for example: *.txt

The next version of Everything will not throw this error and silently fail.
Thanks Void and NotNull for your posts. This is a learning subject for me as well.
Since otherwise, Everything software has been performing A+++ thanks for creating a great software.

Post Reply