Since Update 1.4.1.992

Off-topic posts of interest to the "Everything" community.
Post Reply
eyhabb
Posts: 3
Joined: Fri Oct 16, 2020 5:53 pm

Since Update 1.4.1.992

Post by eyhabb » Fri Oct 16, 2020 5:59 pm

Hello,

I've been facing a problem since update 1.4.1.992. The settings will NOT stay in place. It was working just fine before this update. Every time I started an Everything window it would setup and search just the way I wanted. Now after EVERY search it resets. Please help/advise.

Thanks.

void
Site Admin
Posts: 5732
Joined: Fri Oct 16, 2009 11:31 pm

Re: Since Update 1.4.1.992

Post by void » Sat Oct 17, 2020 12:35 am

This usually occurs when Everything is set to store settings and data in the same location as Everything.

Please make sure Everything is installed correctly:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Store settings and data in %APPDATA%\Everything
  • Click OK.
Please let me know if the issue persists.

eyhabb
Posts: 3
Joined: Fri Oct 16, 2020 5:53 pm

Re: Since Update 1.4.1.992

Post by eyhabb » Sat Oct 17, 2020 4:35 pm

Thank you for your quick reply. I followed your instructions and still get the same unwanted results.

I've set the "Home" tab as follows:

Search: Custom
Filter: Document
Sort: Date Created (Descending) This is the problem it ignores this filter and returns the sort to Name, Ascending.
View: Thumbnails (256x256) (Extra Large)
Index: Local database

Everything else follows the filter criteria except 'sort'. I've uninstalled and reinstalled the program a few times. Set the Home tab as you've recommended and still with every new search term I get the wrong filter layout. I've even tossed out the Everything.ini just so it will re-set anew, no dice. What's driving me crazy is that it was fine prior to the update. So I'm really stuck. Perhaps this is a bug?

void
Site Admin
Posts: 5732
Joined: Fri Oct 16, 2009 11:31 pm

Re: Since Update 1.4.1.992

Post by void » Sat Oct 17, 2020 8:52 pm

Everything will only keep the sort order when the current sort is a 'fast' sort.

Please enable date created indexing and fast date created sort:
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Check Index date created.
  • Check Fast date created sort.
  • Click OK.
Index date created and fast date created sort is disabled by default.
Index date modified and fast date modified sort is enabled by default.

eyhabb
Posts: 3
Joined: Fri Oct 16, 2020 5:53 pm

Re: Since Update 1.4.1.992

Post by eyhabb » Tue Oct 20, 2020 12:53 pm

Finally! It worked. Thank you.

I must ask, why all the underlying complexity of switches and knobs for a 'simple' user. Shouldn't it be set to work as described (for the basic user) and let the 'experts' go in and play with these tweaks to suit their needs. Maybe consider an Advanced Mode and Basic Mode so basic users can jump right in with a few personal tweaks and pro users can flip the switch and go crazy. :)

Thanks again.

Post Reply