Everything-1.4.1.992.x86.Lite-Setup silent switch

Found a bug in "Everything"? report it here
Post Reply
arunregalstar
Posts: 2
Joined: Wed Nov 04, 2020 5:26 am

Everything-1.4.1.992.x86.Lite-Setup silent switch

Post by arunregalstar » Wed Nov 04, 2020 5:40 am

Whats the silent switches for latest Everything:

"D:\1\Everything-1.4.1.992.x86.Lite-Setup.exe" /S -install-options "-app-data -install-service -install-service-port 15485 -install-start-menu-shortcuts -uninstall-desktop-shortcut -uninstall-efu-association -uninstall-folder-context-menu -uninstall-run-on-system-startup -uninstall-url-protocol -disable-update-notification -uninstall-quick-launch-shortcut -language 1033" /D=C:\Program Files\Everything

this cmd works well for older versions of everything. but not
work for latest setup that too its shows -options help page when executing the file.
what am i doing wrong? whats the correct cmd to achieve the above configs

void
Site Admin
Posts: 5808
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything-1.4.1.992.x86.Lite-Setup silent switch

Post by void » Wed Nov 04, 2020 8:19 am

Thank you for the bug report.

Support for -install-service-port 15485 was dropped in Everything 1.4.

It has been replaced with -install-service-pipe-name <name>.

Please try either:

1) Installing with:

"D:\1\Everything-1.4.1.992.x86.Lite-Setup.exe" /S -install-options "-app-data -install-service -install-start-menu-shortcuts -uninstall-desktop-shortcut -uninstall-efu-association -uninstall-folder-context-menu -uninstall-run-on-system-startup -uninstall-url-protocol -disable-update-notification -uninstall-quick-launch-shortcut -language 1033" /D=C:\Program Files\Everything

Note the removal of -install-service-port 15485

-or-

2) Please try the latest nightly build, which will silently ignore -install-service-port instead of displaying an error message.

For more information, please see: Silent installation.

arunregalstar
Posts: 2
Joined: Wed Nov 04, 2020 5:26 am

Re: Everything-1.4.1.992.x86.Lite-Setup silent switch

Post by arunregalstar » Wed Nov 04, 2020 11:26 am

Thanks for the Reply. Working great.

Post Reply