Exclude folders not working

Found a bug in "Everything"? report it here
Post Reply
kumar
Posts: 19
Joined: Fri Sep 27, 2019 1:16 am

Exclude folders not working

Post by kumar » Mon Sep 28, 2020 2:42 pm

I added drive letters to the exclude folders list (see below for the contents from .ini file), but when I plug in my external drives everything search still appears to index them and lock the drive because when I eject the drive I get a message saying cannot eject drive locked by a program and when I exit everything search then I can eject the drive. The exclude folders is definitely not working.

exclude_list_enabled=1
exclude_hidden_files_and_folders=0
exclude_system_files_and_folders=0
include_only_files=
exclude_files=

exclude_folders="E:\\","F:\\","H:\\","I:\\","J:\\","K:\\","L:\\","M:\\","N:\\","O:\\","G:\\"

Also, sometimes when I want to delete a file or a folder, I get a message cannot delete the file or folder, but when I exit everything search I can delete the file or folder that appears to have been locked by everything search. Now, this does not happen all the time, but sometimes.

therube
Posts: 2718
Joined: Thu Sep 03, 2009 6:48 pm

Re: Exclude folders not working

Post by therube » Tue Sep 29, 2020 4:03 pm

What version of Everything?

On your end, do you have things set up such that these drive letters are (essentially) static?
IOW, when you plug in E:, it always shows up as E:, & not sometimes as E: & other times as F: or Z:?

These drives, are they seen by the OS as "fixed" or "removable"?

void
Site Admin
Posts: 5731
Joined: Fri Oct 16, 2009 11:31 pm

Re: Exclude folders not working

Post by void » Wed Sep 30, 2020 6:18 am

These drives may still be included as NTFS volumes.

Please exclude any NTFS volumes:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically include new fixed volumes.
  • For each NTFS volume:
    • Uncheck Include in database for volumes you wish to exclude.
  • Click OK.
Adding volumes to the exclude list is in development.

Post Reply