Everything won't exclude paths with special characters

Found a bug in "Everything"? report it here
Post Reply
juzzle
Posts: 18
Joined: Sat Apr 11, 2020 1:07 am

Everything won't exclude paths with special characters

Post by juzzle » Thu Jul 16, 2020 9:35 pm

I've noticed that it's not possible to add Exlcude paths with special characters, for example "Best photos 🖤". Even if I enter the 8.3 version of the path as an exclude path, it first seems to resolve it to the full name, so that potential workaround doesn't work either. Any updates on when this might be addressed?

void
Site Admin
Posts: 5543
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything won't exclude paths with special characters

Post by void » Thu Jul 16, 2020 11:20 pm

Thank you for the bug report.

Everything was not copying 4-byte UTF-8 characters correctly for excludes.

Please try the latest nightly build for a fix.

You will also need to perform a rebuild to update your excludes:
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Click Force Rebuild.
  • Click OK.
-Alternatively, please try the following exclude filter-

regex:^c:\\folder\\Best photos 🖤$

juzzle
Posts: 18
Joined: Sat Apr 11, 2020 1:07 am

Re: Everything won't exclude paths with special characters

Post by juzzle » Sat Jul 18, 2020 5:16 am

Thanks David - awesome response time!

Post Reply