"6" appears before all alphabetical results [Version 1.4.1.969 (x64)]

Found a bug in "Everything"? report it here
Post Reply
sotiriadis
Posts: 2
Joined: Thu Jul 16, 2020 4:07 am

"6" appears before all alphabetical results [Version 1.4.1.969 (x64)]

Post by sotiriadis » Thu Jul 16, 2020 4:13 am

hello all,
I've been a user of "search everything" for quite some time.
I installed Version 1.4.1.969 (x64) on a new laptop. After a few weeks the folllowing bug appeared.
Whenever a perform a search, "6" appears before all filenames that start with an alphabetical character
for example, if I search for "new" I will get something like this:

6newfilename.txt
6newfilename2.txt
(newfilename3.txt
9newfilename4.txt

where the original filenames would be

newfilename.txt
newfilename2.txt
(newfilename3.txt
9newfilename4.txt

Is there a reason for this behaviour?

void
Site Admin
Posts: 5731
Joined: Fri Oct 16, 2009 11:31 pm

Re: "6" appears before all alphabetical results [Version 1.4.1.969 (x64)]

Post by void » Thu Jul 16, 2020 6:18 am

Corrupt database most likely.

Please try forcing a rebuild:
  • Completely exit Everything (right click the Everything system tray icon and click Exit)
  • In Windows Explorer, type in the following address:
    %LOCALAPPDATA%\Everything
  • Delete your Everything.db
  • Restart Everything.
  • Everything will perform a fresh rebuild.
Please make sure your Everything database is stored on a local disk.
Corruption is possible when storing the Everything database on a removable volume during system shutdown.
You can configure the Everything database location from Tools -> Options -> Indexes -> Database location.

If this is blank, it means the database is stored in %LOCALAPPDATA%\Everything

sotiriadis
Posts: 2
Joined: Thu Jul 16, 2020 4:07 am

Re: "6" appears before all alphabetical results [Version 1.4.1.969 (x64)]

Post by sotiriadis » Thu Jul 16, 2020 10:15 am

yep, this solved it.
thanks!

Post Reply