Page 1 of 1

Everything BETA 'Updating database'

Posted: Tue Jul 14, 2020 9:08 am
by Debugger
The latest beta version Version 1.4.1.984 (x64) does not start correctly. I see 'Updating database' all the time
Version Version 1.4.1.969 (x64) (x64) - shows the same thing, but the results are much faster ...

Re: Everything BETA 'Updating database'

Posted: Tue Jul 14, 2020 9:28 pm
by void
The updating database code hasn't changed from 969 to 984.

Check you are indexing the same files with the same indexing settings (Tools -> Options -> Indexes).

Everything 984 might be getting stuck processing a USN Journal change? -Does the debug console show Everything 984 processing any changes when "Updating database" is shown in the status bar?
  • In Everything 984, when Everything shows "Updating database" in the statusbar, type in the following search and press ENTER
    /debug
  • This will show the debug console.
  • Do you see Everything processing changes in Cyan color?
To close the debug console:
  • In Everything, type in the following search and press ENTER
    /debug
Please try deleting your Everything.db before running Everything 984 to force a fresh rebuild.

Re: Everything BETA 'Updating database'

Posted: Wed Jul 15, 2020 1:59 am
by void
Please make sure Debug logging is disabled.
  • In Everything, type in the following search and press ENTER:
    /debug_log=0
  • If successful, you should see debug_log=0 in the status bar for a few seconds.
  • Restart Everything to ensure setting is saved:
  • In Everything, type in the following search and press ENTER:
    /restart
If you installed version 979 or 980 debug logging may have been enabled.