[unrelated, it seems] 985 - delays in opening 2nd time

Found a bug in "Everything"? report it here
Post Reply
minsik
Posts: 14
Joined: Fri Jan 25, 2013 10:57 pm
Location: Adelaide, South Australia

[unrelated, it seems] 985 - delays in opening 2nd time

Post by minsik » Fri Jul 10, 2020 3:09 pm

ie Everything 854 Windows 64bit installer downloaded and installed over the top of 984.

I have a shortcut open window and minumise window as control+F2 which works a treat. Now with 985 the window opens first time fast, 2nd time closes fast. Then press key combination and window wont open. Delays range from severl seconds to a few minutes. then all the key presses open many windows at once.
Also while the Window is not opening the icon in the taskbar is unresponsive too.
Reverting back to 969 install version works as expected. Toggle control+F2 opens and closes the window as fast and as many times as i want.

seems like a timing thing, but may be related to other reports of unresponsive.

Oh No it seems something in the computer is doing it. Damm. Sorry for the report and cant delete the post! its happening again.
Last edited by therube on Fri Jul 10, 2020 8:14 pm, edited 1 time in total.
Reason: update thread with the cause, if you would

void
Site Admin
Posts: 5746
Joined: Fri Oct 16, 2009 11:31 pm

Re: [unrelated, it seems] 985 - delays in opening 2nd time

Post by void » Mon Jul 13, 2020 7:11 am

Somes guesses:

Everything may have been busy processing updates.
Try killing the Everything process, deleting your Everything.db to force a fresh rebuild:
  • Press Ctrl + Shift + ESC to open the Task Manager.
  • Select your Everything process (if there are two, ignore the one running as system - The Everything Service)
  • Click End Task.
  • Click End Task.
  • In Windows Explorer, navigate to %LOCALAPPDATA%\Everything
  • Delete your Everything.db
  • Restart Everything.
    -This will force Everything to build a fresh database rather than attempt to update the database from the USN Journal
The Everything Service might have been busy.
One process may cause the Everything Service to block.
Everything will appear to hang for 1 minute until it timeouts.
Please make sure the Everything Service is installed and running:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service (Please make sure this is tick-checked and not square-checked).
  • Uncheck Run as administrator.
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.
Everything might be trying to run as an administrator, please run Everything as a standard user:
-Running Everything as an administrator can cause communication delays between other programs.
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service (Please make sure this is tick-checked and not square-checked).
  • Uncheck Run as administrator.
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.
    -
  • Right click your Everything.exe or a shortcut to Everything
  • Click Properties.
  • Click the Compatibility tab.
  • Uncheck Run this program as an administrator.
  • Click OK.
If the issue persists, please send a mini crash dump.

Post Reply