Difficult to index a large number of files and folders :(

Found a bug in "Everything"? report it here
Post Reply
chivo
Posts: 3
Joined: Sat Dec 07, 2019 11:21 pm

Difficult to index a large number of files and folders :(

Post by chivo » Sat Dec 07, 2019 11:36 pm

Difficult to index a large number of files and folders :(



Image


I have been using this valuable software for a long time and I sincerely congratulate you on it. But it's been a problem for a couple of days, which annoys me a lot, and whatever I do, the software doesn't work as before. The problem is that a few days ago I noticed that many of the files and folders in my system were not indexed and the program was unable to find them. I uninstalled and reinstalled the program and even tried the previous version but the problem didn't work. In fact, many of my system files, most of which are music files, are not indexed at all and are not displayed in search results. Thanks for guiding me ???

void
Site Admin
Posts: 5238
Joined: Fri Oct 16, 2009 11:31 pm

Re: Difficult to index a large number of files and folders :(

Post by void » Sat Dec 07, 2019 11:58 pm

Please make sure no search options are checked under the Search menu (eg: uncheck match case, uncheck match whole words, uncheck regex)

Please make sure the Everything filter is active under the Search menu.

Please make these files are not excluded from Tools -> Options -> Exclude.

Please try forcing a rebuild:
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Click Force Rebuild.
  • Click OK.
Please let me know if the issue persists.

chivo
Posts: 3
Joined: Sat Dec 07, 2019 11:21 pm

Re: Difficult to index a large number of files and folders :(

Post by chivo » Sun Dec 08, 2019 7:15 am

Hi dear void, I checked all the parts you mentioned and all were in the correct settings and defaults, I even tried the previous versions and the 32 bit version but still does not index a specific file each time and does not recognize them And it doesn't show. Interestingly, each time he does not know the specific file and folder. I'm really confused and I don't know why. All program settings are in the correct state and the default state. It also detects 1.327.024 objects. It uses exactly the term "object".
Interestingly, using the "Force Rebuild" option reduced the number of files to the current number of 1.326.958 and is also slowly changing.

void
Site Admin
Posts: 5238
Joined: Fri Oct 16, 2009 11:31 pm

Re: Difficult to index a large number of files and folders :(

Post by void » Sun Dec 08, 2019 10:15 am

Please check if Everything is finding orphaned files:
  • In Everything, type in the following search and press ENTER:
    /debug
  • Type in the following search and press ENTER:
    /reindex
    Look for the following Yellow text in the debug console:
    removed 5 orphaned files in 0.040024 seconds
    removed 2 orphaned folders in 0.006590 seconds
How many orphaned files and folders are removed?

If there are many (100+), please make a backup of this drive ASAP.
Note: It's normal for there to be 1000s of orphaned files if you are excluding files in Tools -> Options -> Exclude.

To close the debug console:
  • In Everything, type in the following search and press ENTER:
    /debug
Please check your drive for errors:
  • Please backup anything important on your drive before checking it for errors.
  • In Windows Explorer, right click your drive and click Properties.
  • Click the Tools tab.
  • Click Check now...
  • Click Start
  • If prompted to schedule a scan on the next restart, click Yes.

chivo
Posts: 3
Joined: Sat Dec 07, 2019 11:21 pm

Re: Difficult to index a large number of files and folders :(

Post by chivo » Mon Dec 09, 2019 5:40 am

Hi dear void, I did what you said but the problem was not solved. After reviewing what changes I've made to the system over the past few days and what software I have installed, I find that the latest software I have installed is CCleaner. And I used the registry cleaner to clean the system. I figured that maybe the changes that " CCleaner " made to the registry were causing this problem. Then using another software I restored all registry settings to default and then reinstalled " everything " again, apparently the problem was resolved and for now I didn't see any problems.
Maybe, of course, maybe ( I guess ) the cause of this problem was the changes that the " CCleaner " software had made to the registry, but now the problem has just been resolved, thanks for your valuable support and follow up, dear friend :)

I had a question about when the next update to this software would be released ???

Post Reply