Not saving some NTFS preferences

Found a bug in "Everything"? report it here
Post Reply
rogeriodec
Posts: 5
Joined: Sat Jul 21, 2018 7:04 pm

Not saving some NTFS preferences

Post by rogeriodec » Fri Sep 13, 2019 1:51 pm

I have a backup script to an external USB HDD (h:).
When the backup is finished, I can't dismount this drive.
The USB Safely Remove program shows that Everything is blocking this drive:
Image

But I have previously unselected all options for this drive in Options -> Index -> NTFS:
Image

However, Everything is not keeping the "Enable USN Journal" unchecked. After applying the uncheck and opening the preferences again, it is showing checked again:
Image

This way Everything seems to block this drive constantly.

void
Site Admin
Posts: 5469
Joined: Fri Oct 16, 2009 11:31 pm

Re: Not saving some NTFS preferences

Post by void » Mon Sep 16, 2019 4:20 am

Thanks for the bug report.

Everything will automatically create the USN Journal if you have Monitor changes enabled.
I see you have this setting disabled.

The USN Journal can also be recreated by other software or Windows itself.

There could be a pending delete on the USN Journal. Restarting your PC should complete the USN Journal deletion.

rogeriodec
Posts: 5
Joined: Sat Jul 21, 2018 7:04 pm

Re: Not saving some NTFS preferences

Post by rogeriodec » Mon Dec 09, 2019 2:11 pm

Just to report that the problem continues to occur ...

therube
Posts: 2577
Joined: Thu Sep 03, 2009 6:48 pm

Re: Not saving some NTFS preferences

Post by therube » Mon Dec 09, 2019 3:57 pm

Make sure your backup script is not running.

Ensure that you are working with, looking at, the "correct" Everything.ini (in case you have more then one).
(Might be better searching for:
everything .ini
.)

Make the changes to Everything, deselecting H:.

Quit Everything.

Restart Everything.

Is H: enabled again?

rogeriodec
Posts: 5
Joined: Sat Jul 21, 2018 7:04 pm

Re: Not saving some NTFS preferences

Post by rogeriodec » Mon Dec 09, 2019 4:12 pm

The correct path for everything.ini should be C:\Users\myuser\AppData\Roaming\Everything\Everything.ini.
There I see:

Code: Select all

ntfs_volume_paths="C:","E:","H:"
However, as you can see in the images above, the "remove" button is greyed out for "H:" (my external HDD).

But, quitting Everything.exe first, then removing manually H: from the line above, it makes no difference, ie, H: keeps appearing there and the "remove" button keeps greyed out.

void
Site Admin
Posts: 5469
Joined: Fri Oct 16, 2009 11:31 pm

Re: Not saving some NTFS preferences

Post by void » Thu Dec 12, 2019 7:42 am

Windows will automatically recreate the USN Journal on next boot. It's possible another application is recreating it too.

Everything will create the USN Journal if you have checked Include in database and Monitor Changes under Tools -> Options -> NTFS.

Everything should not open any handles to this volume if "Include in database" is unchecked.

Can you please confirm, your H: drive is not listed under Tools -> Options -> ReFS.
Can you please confirm, your H: drive is not listed under Tools -> Options -> Folders.
However, as you can see in the images above, the "remove" button is greyed out for "H:" (my external HDD).
The remove option is disabled/greyed out when the volume is online. Use the Include in database option to exclude this volume.

Post Reply