[FIXED] "everything" sometimes calculates occupied space completely wrong

Found a bug in "Everything"? report it here
jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

[FIXED] "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Sat Sep 30, 2017 8:43 pm

1. example:
Image
those 3 folders actually are completely empty after i moved a lot of jpegs to another folder

2. example: (screenshot within total commander to make it easier visible, space is calculated by "everything".
Image

also, once moved the whole content of a folder to another one, and instead "zero", "everything" showed negative numbers.

this happened many times now here, on external hard disks.
Win 7
external USB drive, encrypted by Verycrypt (NTFS)
Everything 1.4.1.877 32bit


only rebuilding the database helps.
Last edited by jazmomo on Mon Nov 27, 2017 2:09 pm, edited 1 time in total.

therube
Posts: 1740
Joined: Thu Sep 03, 2009 6:48 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby therube » Sun Oct 01, 2017 11:41 am

Does the Tracks directory contain "links" of some sort (or junctions)?

Does this occur only on the encrypted drive?
Does this occur on all directories on the encrypted drive or only some?


Is your screenshot also showing that the TC directory calculation is also incorrect?

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Sun Oct 01, 2017 8:06 pm

1) they are plain directories with absolutely nothing in them.

2) hard to tell, my system disk is small, the others all encrypted. i will keep an eye on it.

3) only on very few. so its' (unfortunately) kinda hard to reproduce. but it seems to happen if there's a lot of activity in a directory, lets say unpacking lots of files using a simple batch script.

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Mon Oct 02, 2017 9:08 pm

ok, checked it. it happens on my un-encrypted system drive too.

i could easily reproduce this time:

but it seems to happen if there's a lot of activity in a directory, lets say unpacking lots of files using a simple batch script.

what i did. had lots of ZIP files (a directory with 2 subdirectories), unpacked them via batch (ended up with 8500 files), deleted the zips, moved the 8500 files to another directory (same drive). et voilà... same as in picture 1, both the now empty subdirectories are calculated wrong.

but when i move those 2 subdirs to another place as well, "everything" seems to be fine again. :?

void
Site Admin
Posts: 3607
Joined: Fri Oct 16, 2009 11:31 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby void » Wed Oct 04, 2017 12:53 am

If the issue is reproducible could you please send some verbose debugging information:
  • In Everything, type in the following search and press ENTER:
    /verbose
  • Type in the following search and press ENTER:
    /debug
  • Reproduce the issue.
  • Please send the debug output to support@voidtools.com

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Fri Oct 06, 2017 3:40 pm

i will do so, next time i have to unpack a bunch of files.

void
Site Admin
Posts: 3607
Joined: Fri Oct 16, 2009 11:31 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby void » Wed Nov 01, 2017 5:08 am

Please try Everything 1.4.1.885.

Everything 1.4.1.885 fixes a bug where not all file sizes are calculated correctly after renaming a folder.

Everything-1.4.1.885.x86.zip
Everything-1.4.1.885.x64.zip

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Wed Nov 01, 2017 4:48 pm

cool, thanks.

it wasn't as easy to reproduce as expected. it happened again here and there, but never when it was in /debug mode. and as soon as i noticed it was too late, the debug window output buffer was overwritten with newer stuff. :x
i even packed and unpacked hundreds of small jpg files in a test folder, but no problems there. :?

i wonder if this really happens only here? :shock: i am using the x86 version because it eats less RAM, which is a good thing on my older notebook.
but maybe i should try the x64 version too. although, i doubt it would make a difference.

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Sat Nov 04, 2017 10:02 pm

so far it looks good, let's keep fingers crossed. 8-)

jazmomo
Posts: 11
Joined: Thu Aug 18, 2016 12:36 pm

Re: "everything" sometimes calculates occupied space completely wrong

Postby jazmomo » Fri Nov 17, 2017 11:18 pm

still fine. :D

sorry for spamming, but i'm still not 100% sure, although it should be ok now.


Return to “Bug report”