Everything 1.4 Known Issues

Found a bug in "Everything"? report it here
Post Reply
Site Admin
Posts: 6531
Joined: Fri Oct 16, 2009 11:31 pm

Everything 1.4 Known Issues

Post by void » Tue Oct 06, 2015 8:33 am

Things to do

Everything 1.4 known issues:
  • [FIXED in 809b] when exclude hidden files is enabled, hiding a folder hides the parent instead.
  • [FIXED in 809b] rc: is disabled, use dm: (rc: can be enabled from Tools -> Options -> Indexes -> Index recent changes)
  • [FIXED in 770b] ReFS indexing not working for small system pages (small volumes).
  • [FIXED in 713b] subst indexes are lost after re-indexing.
  • [FIXED in 713b] inline renaming doesn't obey listview wrapping rules: wrap with search.
  • [FIXED in 709b] ReFS indexing not working for some volumes.
  • [FIXED in 709b] Folder indexes not updating recent changes.
  • [FIXED in 709b] Folder indexes not updating folder information (date modified/attributes).
  • [FIXED in 709b] Rebuilding is not using existing folder/filelist indexes.
  • [FIXED in 709b] Rendering issue when preview is enabled.
  • [FIXED in 709b] Selection mask not invalidating old hovered items.
  • [FIXED in 709b] Old service detection needs improvement.
  • [FIXED in 709b] Missing NTFS files when a mft fragment is too large (>2GB).
  • [FIXED in 705b] Service 1.3 and 1.4 are incompatible, only one can be installed at a time.
  • [FIXED in 704b] Corruption in file names and size information on some volumes.
  • [FIXED in 704b] size and date information missing when the file is opened by the system.
  • [FIXED in 704b] subst volumes indexing the entire volume.
  • [FIXED in 704b] floppy disk access on indexing.
  • [FIXED in 704b] -update -exit doesn't udpate database on disk if it does not exist or is out of date.
  • [FIXED in 704b] Multi-file renaming not working for some non-ascii text.
  • [FIXED in 703b] Included volumes reset when auto include fixed volumes is unchecked in the installer

Posts: 1
Joined: Fri Nov 13, 2015 1:35 am

Re: Everything 1.4 Known Issues

Post by chappjc » Fri Nov 13, 2015 1:43 am

I'm not clear on the status of indexing subst volumes. What I have observed is that moving from 1.3 to 1.4 has made it impossible to see search results for subst volumes, even though according to the NTFS ui dialogs they can be indexed and included in the database. It all looks good, but there are 0 objects included in the database. This used to work. Is there a workaround (besides folder indexing) or is this currently broken?

Thanks for the great product! The new fast size sorting capability is a major win.

Note: I observe the subst issue on Windows Server 2003 R2, running the Everything service. I've tried running subst as administrator since their are no UAC tricks to pull on this OS.

EDIT: Of course, I figure out a solution 10 minutes after posting... After toggling things off/on, I managed to get objects from the source NTFS drive (E:) as well as the subst drive (M:\ => E:\Storate) included in the database. But the remaining trick was getting rid of the E:\ results because when I turned off "Include in database" for E: (but keeping USN Journal enabled!), all the objects on M: would vanish from the results. This used to work. Now the workaround was in Exclude to "Add filter" (not "Add folder") and enter "E:\*". Now on a client computer with a M: mount, everything in the ETP results is accessible quite naturally.

Posts: 13
Joined: Sun Apr 17, 2011 4:00 pm

Re: Everything 1.4 Known Issues

Post by rgbigel » Tue Dec 08, 2015 5:28 pm

Unable to install Everything as a service On Win 10 64 Bit build 10586(.17)
[Now runing it as Administrator w/o problems]
Messagebox (retranslated from German): Everything system service: 1072 can not be created
Event log:
Fehlerbucket 128958149927, Typ 5
Ereignisname: RADAR_PRE_LEAK_WOW64
Antwort: Nicht verfügbar
CAB-Datei-ID: 0

P1: LookeenDesktopSearch.exe
P3: 10.0.10586.2.0.0

Angefügte Dateien:

Diese Dateien befinden sich möglicherweise hier:

Es wird erneut nach einer Lösung gesucht: 0
Berichts-ID: 1e5b7df8-9dce-11e5-9bdc-0090278e01ba
Berichtstatus: 0
Bucket mit Hash: c1025642d9699f1f75081ae6405adbeb

Posts: 2890
Joined: Thu Sep 03, 2009 6:48 pm

Re: Everything 1.4 Known Issues

Post by therube » Tue Dec 08, 2015 10:04 pm

How are you attempting to install Everything Service?

Are you using installer or zip?
Will the service install from the command-line? From within the program itself?

Site Admin
Posts: 6531
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything 1.4 Known Issues

Post by void » Tue Dec 08, 2015 10:52 pm

Messagebox (retranslated from German): Everything system service: 1072 can not be created
An existing Everything Service is pending deletion.

Normally this should not occur.
This can happen if there was a problem closing/deleting an existing Everything service.

Rebooting Windows (so the service can be deleted on Windows startup) and re-installing Everything should fix the problem.

Posts: 35
Joined: Sun Mar 08, 2015 11:05 pm

Re: Everything 1.4 Known Issues

Post by aussieboykie » Wed May 04, 2016 4:55 am

Not sure if this covered by the SUBST issues listed above.

In my case, SUBST drives are still being indexed after having been deleted. Specifically... earlier today I used SUBST to create S: and T: pseudo-drives mapped to folders which I subsequently deleted with (e.g.) SUBST S: /D. Now when I search for files I am seeing duplicate entries mapped to S: and T: drives which no longer exist.

I tried Tools --> Options --> Force Rebuild and saw "Scanning Removable Disk (S:)" and "Scanning Removable Disk (T:)" messages during the process and the duplicates on S: and T: are still present after the rebuild. Just to be sure, I checked with both SUBST and Disk Manager to confirm that there are no S: or T: drives present on the W7 system.

Regards, AB

Post Reply