weird problem,only usb hardisk is indexed

Found a bug in "Everything"? report it here
Post Reply
sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

weird problem,only usb hardisk is indexed

Post by sanji765 » Wed Mar 27, 2013 6:59 am

Unable to solve problem::::
--uses 1.3 beta
--everything runs in admin mode
--tried resetting the everything.ini (by deleting)and rebuilding the index
--only portable drive H,is listed
--USN journal logging button is "Grayed out" in all other drives,other than drive H,which is portable usb hardisk
---tried the old version of everything,it works

Why are the other drives not indexed----?
Why is USN journal logging button "Grayed out" --?
why is the old version working--?
everything was working fine before
if you want everything.ini,e-mail me
You do not have the required permissions to view the files attached to this post.

therube
Posts: 2373
Joined: Thu Sep 03, 2009 6:48 pm

Re: weird problem,only usb hardisk is indexed

Post by therube » Wed Mar 27, 2013 3:38 pm

Anything related noted in Errorlog.txt ?

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Wed Mar 27, 2013 7:37 pm

Errorlog.txt ,there is no error log,i dont understand whats wrong,usually i could figure out,and reseting everything.ini worked,but not now

void
Site Admin
Posts: 4994
Joined: Fri Oct 16, 2009 11:31 pm

Re: weird problem,only usb hardisk is indexed

Post by void » Wed Mar 27, 2013 8:11 pm

This will occur if Everything can not read the USN Journal on the drive.

Please make sure Everything is running with administrative rights or the Everything service is running.

From an cmd prompt with administrative rights, what do the following commands display:

Code: Select all

fsutil fsinfo volumeinfo c:
fsutil fsinfo ntfsinfo c:

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Fri Mar 29, 2013 7:38 am

now i am getting errors from this site:::
when trying to upload .png's i get=The image file you tried to attach is invalid.
when i try to upload .rar instead=Temporary folder could not be found. Please check your PHP installation.

---the results of running those cmd's looked fine
---now everything running in admin mode(it runs as admin by default,i set it from properties),but show no result,till yesterday it indexed my portable hdisk
--the old version is able to index all drives in my pc

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Fri Mar 29, 2013 7:52 am

Problem solved,but Dont know how=
what i did=i was running everything as a portable app,i downloaded the installable version and installed it to c drive,and it runs as a service now,it indexed all drives,i exited installed version and ran,the portable verion,now the portable version also works,so there is some problem with the portable version,i suspect.

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Fri Mar 29, 2013 8:00 am

8-)
Last edited by sanji765 on Fri Mar 29, 2013 8:46 am, edited 1 time in total.

void
Site Admin
Posts: 4994
Joined: Fri Oct 16, 2009 11:31 pm

Re: weird problem,only usb hardisk is indexed

Post by void » Fri Mar 29, 2013 8:43 am

Please run Everything in debug mode.

Please open the NTFS options page, from the Tools -> Options menu.

You should see the following line:

Code: Select all

failed to query USN Journal xx
-or-

Code: Select all

CreateFileW(): GetLastError(): xx: Failed to open volume C:
Which message do you see, and what is the xx code?

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Fri Mar 29, 2013 8:48 am

i finally got an error log:::
29-03-2013 19:34: Everything 1.3.1.636b: .\src\os.c(5729): os_get_usn_journal(): DeviceIoControl(00000320,FSCTL_QUERY_USN_JOURNAL,0,0,0413f038,56,0413eedc,0): 87: Failed to query USN Journal.

i have unistalled everything and i am using the portable version,its working without having to install the service,i now strongly believe that there are compatibility issues with emsisoft antimalware,
how to know if emsisoftt antimalware is causing the probblem=if your portable build dose not allow you to install the everything service,but gives you an error,even if its running as admin and have emsisoft antimalware running,then you have to manually remove Everything.exe's application rule from emsisoft antimalware application rules

therube
Posts: 2373
Joined: Thu Sep 03, 2009 6:48 pm

Re: weird problem,only usb hardisk is indexed

Post by therube » Fri Mar 29, 2013 1:34 pm

> if your portable build dose not allow you to install the everything service

It does.
From the command line: Everything.exe -install-service

void
Site Admin
Posts: 4994
Joined: Fri Oct 16, 2009 11:31 pm

Re: weird problem,only usb hardisk is indexed

Post by void » Fri Mar 29, 2013 1:48 pm

29-03-2013 19:34: Everything 1.3.1.636b: .\src\os.c(5729): os_get_usn_journal(): DeviceIoControl(00000320,FSCTL_QUERY_USN_JOURNAL,0,0,0413f038,56,0413eedc,0): 87: Failed to query USN Journal.
This error can occur if a device was unplugged while Everything was monitoring it for changes.
i have unistalled everything and i am using the portable version,its working without having to install the service,i now strongly believe that there are compatibility issues with emsisoft antimalware,
You may need to allow the Everything service to communicate on 127.0.0.1:15485 with emsisoft antimalware.

sanji765
Posts: 7
Joined: Wed Mar 27, 2013 6:47 am

Re: weird problem,only usb hardisk is indexed

Post by sanji765 » Sat Mar 30, 2013 11:43 am

thanks,all problems solved

therube
Posts: 2373
Joined: Thu Sep 03, 2009 6:48 pm

Re: weird problem,only usb hardisk is indexed

Post by therube » Sun Mar 31, 2013 5:07 pm

How?

Post Reply