Page 1 of 1

Losing settings multiple times

Posted: Tue Apr 06, 2021 9:46 pm
by rogeriodec
For some reason, everything is losing the settings I make, for example, to open the folder by double-clicking.
I've had to redo these settings several times.
What could be wrong?

Re: Losing settings multiple times

Posted: Wed Apr 07, 2021 10:51 am
by Irishman
I came here to write about the same problem I had yesterday, and then I saw your article. I need help too.

Re: Losing settings multiple times

Posted: Wed Apr 07, 2021 10:51 am
by void
Please make sure Everything is installed correctly:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Store settings and data in %APPDATA%\Everything (important)
  • Uncheck Run as administrator.
  • Check Everything Service. (Please make sure this is tick-checked and not square-checked)
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.
Does the issue persist?

Re: Losing settings multiple times

Posted: Wed Apr 07, 2021 11:41 am
by rogeriodec
Thanks for your response.
All items you mentioned are ok.
I uninstalled it completely, cleaned the windows registry, and reinstalled it.
I'll wait now to see what happens.

Re: Losing settings multiple times

Posted: Wed Apr 07, 2021 12:56 pm
by void
Please check for any other installations of Everything that might be interfering with your normal installation.
Some third party tools bundle Everything.exe which interfere with your normal installation.

Are there any other Everything.exe files on your computer?

If you are using the x64 version of Everything, please try uninstalling the x86 version of Everything.
If the x86 version was installed, please reinstall the x64 version.

Re: Losing settings multiple times

Posted: Thu Apr 08, 2021 12:46 pm
by rogeriodec
None of the conditions you mentioned above ...
But: uninstalling, cleaning the registry, and reinstalling, after a day, nothing has been lost yet. :idea:

Re: Losing settings multiple times

Posted: Fri Apr 09, 2021 6:15 pm
by rogeriodec
Sorry, but today the problem happened again...
Where are these settings stored?

Re: Losing settings multiple times

Posted: Sat Apr 10, 2021 12:33 am
by void
Settings are stored in two files.

The first is the Everything.ini in the same location as your Everything.exe

Please make sure this Everything.ini contains the following line:
app_data=1

This will redirect Everything to load your settings from Everything.ini in %APPDATA%\Everything