New iscsi drive not listed in Local NTFS Volumes

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
kreed12
Posts: 3
Joined: Mon Jul 29, 2019 11:01 pm

New iscsi drive not listed in Local NTFS Volumes

Post by kreed12 » Tue Mar 16, 2021 1:54 pm

Hello,

I've just added a new iSCSI drive to a server and when I go to add it to the Local NTFS Volumes in the options it is not visible. I've tried enabling the "Automatically Include" option, removing the drive and re-adding it. Can't seem to get it to show up.

The drive is visible in disk manager and mounted on a folder. I can browse the drive and save items to it.

This is the 17th iSCSI drive if that is helpful. Never had this issue until now.

void
Site Admin
Posts: 6454
Joined: Fri Oct 16, 2009 11:31 pm

Re: New iscsi drive not listed in Local NTFS Volumes

Post by void » Wed Mar 17, 2021 5:19 am

Thank you for the bug report kreed12,

Could you please send some debug output:
  • In Everything, please make sure the options page is closed.
  • In Everything, type in the following search and press ENTER:
    /debuglog
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Close the options window.
  • In Everything, from the File menu, click Exit.
  • Restart Everything
  • Please send me your %TEMP%\Everything Debug Log.txt
The debug logs will contain what volumes Everything can see.

You may need to manually add this volume:
  • Completely exit out of Everything, right click the Everything system tray icon and click Exit.
  • Open your %APPDATA%\Everything\Everything.ini
  • Change the following lines:

    ntfs_volume_guids="\\\\?\\Volume{...}","\\\\?\\Volume{...}"
    ntfs_volume_paths="C:","E:"
    ntfs_volume_roots="",""
    ntfs_volume_includes=1,1
    ntfs_volume_load_recent_changes=0,0
    ntfs_volume_include_onlys="",""
    ntfs_volume_monitors=1,1

    to:

    ntfs_volume_guids="\\\\?\\Volume{...}","\\\\?\\Volume{...}","\\\\?\\Volume{<your New iscsi volume GUID>}"
    ntfs_volume_paths="C:","E:","<your new iscsi mount path>"
    ntfs_volume_roots="","",""
    ntfs_volume_includes=1,1,1
    ntfs_volume_load_recent_changes=0,0,0
    ntfs_volume_include_onlys="","",""
    ntfs_volume_monitors=1,1,1
  • Save changes and restart Everything.
If you need help finding your iscsi volume guid, please let me know, It might be shown in your Everything debug output.

kreed12
Posts: 3
Joined: Mon Jul 29, 2019 11:01 pm

Re: New iscsi drive not listed in Local NTFS Volumes

Post by kreed12 » Wed Mar 17, 2021 2:24 pm

Hey there,

I'm sorry.. taking a second look I had failed to mount it on the folder. I fixed that and it's working fine now.

Post Reply