Page 1 of 1

Everything not finding document contents

Posted: Fri Nov 06, 2020 8:20 pm
by cmaka99
When I search Everything (Windows 10, latest version of Everything) I don't get any matching results for the contents of any document files (Word docs, PDF, etc.). Is there something special I need to do? I've tried rebuilding the index multiple times. The files with content that it should be finding do appear in the file list when I first open Everything.

Re: Everything not finding document contents

Posted: Fri Nov 06, 2020 9:35 pm
by void
Everything does not index file content (yet). Only filenames, size and date modified are indexed.

To search file content, please try the content: search function.

For example, to search for the content "To be or not to be" in docx and pdf files, modified this year, search for:
ext:docx;pdf dm:thisyear content:"To be or not to be"

Note: File content is not indexed. Searching file content will be very slow.
For the best performance, combine the content: search with other search filters.

Please try the Advanced Search under the search menu and set the "A word or phrase in the file" field.
For the best performance, set as many fields in the Advanced Search as possible.

Does Everything find your content when you use the content: search function?

Re: Everything not finding document contents

Posted: Sat Nov 07, 2020 12:57 am
by cmaka99
Thanks for the quick response.

I tried the instructions you provided and initially the program stopped responding. I launched it again and it just seemed to hang on querying, but then I realized that the original process was still hanging around in background. Once I killed both processes and completely relaunched the application, searching for content: worked like a charm. I actually prefer having to use a special command to search file contents, so this is great. Thanks!!