Folder not appearing in index

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
unknownsoldierx
Posts: 8
Joined: Sun Oct 20, 2019 3:56 am

Folder not appearing in index

Post by unknownsoldierx » Thu Jul 16, 2020 10:22 am

I have a folder "x:\x temp" which is not appearing in the index. All other folders and contents seem to be listed. I have no excluded folders set.

Windows error check of the drive is clean. I've tried rebuilding the index and USN Journal.

void
Site Admin
Posts: 5558
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder not appearing in index

Post by void » Thu Jul 16, 2020 10:52 am

Please make sure no search options are checked under the Search menu (eg: uncheck match case, uncheck match whole words, uncheck regex)

Please make sure the Everything filter is active under the Search menu.

Does a force rebuild help?:
  • In Everything, from the Tools menu, click Options.
  • Click the Indexes tab on the left.
  • Click Force Rebuild.
  • Click OK.

unknownsoldierx
Posts: 8
Joined: Sun Oct 20, 2019 3:56 am

Re: Folder not appearing in index

Post by unknownsoldierx » Thu Jul 16, 2020 11:13 am

Sorry. Forgot to mention that no search options are set and it's set to the Everything filter.

Force Rebuild does not help. Also tried disable/enable USN Journal.

void
Site Admin
Posts: 5558
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder not appearing in index

Post by void » Thu Jul 16, 2020 11:24 am

Is "x:\x temp" a folder junction?
Is X: a NTFS volume?

Could you please run Everything in debug mode and reindex your X: drive:
  • In Everything, type in the following search and press ENTER:
    /debug
  • Type in the following search and press ENTER:
    /reindex x:
  • What is shown in the debug console?
  • You should see the following in Yellow color:
    removed x orphaned files in y seconds
    removed x orphaned folders in y seconds
  • Is Everything removing any orphaned files/folders?
To close the debug console:
  • In Everything, type in the following search and press ENTER:
    /debug

unknownsoldierx
Posts: 8
Joined: Sun Oct 20, 2019 3:56 am

Re: Folder not appearing in index

Post by unknownsoldierx » Thu Jul 16, 2020 11:52 am

using existing NTFS index X:
clear old db
copy config copy
exclude folders
exclude files
remove orphaned folder children
create folder indexes, excluded orphaned folders.
allocate file indexes, removing orphaned files.
removed 0 orphaned files in 0.000490 seconds
removed 0 orphaned folders in 0.000035 seconds

void
Site Admin
Posts: 5558
Joined: Fri Oct 16, 2009 11:31 pm

Re: Folder not appearing in index

Post by void » Thu Jul 16, 2020 11:57 am

using existing NTFS index X:
The X: drive appears offline to Everything.

Please check your X: drive under Tools -> Options -> NTFS
Are there multiple X: drives listed here?
Select your X: drive and click Remove for any offline X: drives.

Please check the drive letter is mounted correctly.

unknownsoldierx
Posts: 8
Joined: Sun Oct 20, 2019 3:56 am

Re: Folder not appearing in index

Post by unknownsoldierx » Thu Jul 16, 2020 12:08 pm

There was an offline X: drive, plus a few for other drive letters too, and the active X: wasn't being included.

Problem solved! Thanks!

Post Reply