Everything window stealing focus

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
drakegraves
Posts: 2
Joined: Sat Jul 11, 2020 12:03 am

Everything window stealing focus

Post by drakegraves » Sat Jul 11, 2020 12:10 am

I don't remember it doing this when I first started using it a year or so ago. Most of my time with this application has been amazing, then all of a sudden one day, I hit my hotkey to open a new window, the window pops up, I type my search, hit tab to navigate down to the results list, arrow key to my file/folder, hit enter to open it, and:

Everything is covering my newly opened file or folder. I JUST opened up my result, so intuitively, the window for whatever my result was should be what is in focus, the window on top of everything else, but it's not, it's behind the everything window. All my windows are all behind the everything window no matter what I do, until i move my mouse all the way over and hope to god I hit the tiny minimize button my first try.

I've been quite frustrated in case you can't tell, I downloaded Everything out of frustration with Window's native search, and immediately upon using Everything I felt like "finally, somebody gets it". I still feel that way, but this is more than a minor annoyance, and it never used to happen.

Thanks everybody!

drakegraves
Posts: 2
Joined: Sat Jul 11, 2020 12:03 am

Re: Everything window stealing focus

Post by drakegraves » Sat Jul 11, 2020 12:15 am

Right after posting this I found the "close window on execute" option which helps, but still even in this moment Everything's window is hovering in front of my internet browser obscuring what I'm trying to type - I should be able to just click my browser's window and bring it into focus, right? Was Everything always "always on top" like this? THanks again!

void
Site Admin
Posts: 5543
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything window stealing focus

Post by void » Sun Jul 12, 2020 12:09 am

Please try disabling always ontop:
  • In Everything, from the View menu, under the On Top submenu, click Never (Ctrl + T).

Post Reply