Everything can't view/index remote mounted drive (rclone)

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
qqwertyy
Posts: 1
Joined: Sat Jun 27, 2020 9:58 am

Everything can't view/index remote mounted drive (rclone)

Post by qqwertyy » Sat Jun 27, 2020 10:19 am

So I did a search for 'rclone' in these forums and it turned up 0 results, I guess it's not that popular here.

It's a command line tool that lets you upload files to your cloud storage accounts as well as mount your cloud storage as a drive on Windows, known as a 'remote'.

At the moment I have my Google Drive mounted on Windows with the assigned letter 'T:'
Apart from Everything, it all functions as it should:
  • Windows recognizes the remote
  • I can copy/paste files to and from the remote just like it was a normal local drive
  • I can do a search for files through Windows Explorer (albeit very slowly)
  • Even foobar2000 has indexed every music file in the remote - I just created a symbolic link between the remote and a local folder, told foobar to index that local folder and within a few hours it was done.
Unfortunately I haven't found any way of indexing the mounted 'remote' in Everything. 'T:' doesn't appear in the list of volumes:

Image

and the symbolic link method (using 'mklink') doesn't work, Everything will not accept the local folder that points to the remote:

Image


It's such a shame because I have a lot of files that I access every day on the cloud and Everything is the fastest way I've found to find and open stuff. Does anyone have suggestions on how to get this working?

Peace ;)

horst.epp
Posts: 252
Joined: Fri Apr 04, 2014 3:24 pm

Re: Everything can't view/index remote mounted drive (rclone)

Post by horst.epp » Sat Jun 27, 2020 10:26 am

Non NTFS volumes must be added with folder indexing.

void
Site Admin
Posts: 5458
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything can't view/index remote mounted drive (rclone)

Post by void » Mon Jun 29, 2020 1:31 am

To expand on horst.epp's post:

To add your T: drive to your Everything index:
  • In Everything, from the Tools menu, click Options.
  • Click the Folders tab.
  • Click Add....
  • Select your T: drive and click OK.
  • Click OK.
-If the T: drive is not listed, please try running Everything as a standard user:
  • In Everything, from the Tools menu, click Options.
  • Click the General tab on the left.
  • Check Everything service.
  • Uncheck Run as administrator.
  • Click OK.
  • Exit Everything (right click the Everything tray icon and click Exit).
  • Restart Everything.

Post Reply