Cannot index HDD

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
Cevic
Posts: 4
Joined: Mon Jun 22, 2020 5:41 am

Cannot index HDD

Post by Cevic » Mon Jun 22, 2020 5:50 am

Hello,

so im encountering this isssue while trying to add a new external disk, the issue is that the disk worked for weeks without any issues with everything. The pc can reconize it, there are no errors whatsoever.

Its a NTFS, i tried to force rebuild like suggested but still everything wont add it. Is there any manual way to point it out?

Image

thanks!

void
Site Admin
Posts: 5458
Joined: Fri Oct 16, 2009 11:31 pm

Re: Cannot index HDD

Post by void » Mon Jun 22, 2020 6:01 am

Is the NTFS volume included in your Everything index?

Only fixed NTFS volumes are included by default.

To include removable NTFS volumes in your Everything index:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Select your external disk.
  • Check Include in database.
  • Click OK.

You say the volume is NTFS, for others, if you wish to add non-NTFS volumes to your Everything index:
  • In Everything, from the Tools menu, click Options.
  • Click the Folders tab.
  • Click Add....
  • Select your non-NTFS volume and click OK.
  • Click OK.

Cevic
Posts: 4
Joined: Mon Jun 22, 2020 5:41 am

Re: Cannot index HDD

Post by Cevic » Mon Jun 22, 2020 6:52 am

The disk im trying to add is an NTFS, yes.

Mistakenly i've turned on the pc without it being plugged and for some reasons it didn't read it at all even after rebooting.

To include removable NTFS volumes in your Everything index:

In Everything, from the Tools menu, click Options.
Click the NTFS tab on the left.
Select your external disk.
Check Include in database.
Click OK.
when i try to check this my disk isn't listed (it used to be listed)
Image

now im trying to add it as non-NTFS but im getting an infinite "scanning..."


this is the disk im trying to add
Image


thanks!

void
Site Admin
Posts: 5458
Joined: Fri Oct 16, 2009 11:31 pm

Re: Cannot index HDD

Post by void » Mon Jun 22, 2020 6:58 am

Folder indexing will take a very long time.

With the external drive connected, could you please send a high-res screenshot of the debug console after showing the Tools -> Options -> NTFS page?

-I can't make out the text in the original screenshot.

To keep your volumes in your Everything index when they go offline, please uncheck automatically remove offline volumes:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically remove offline volumes.
  • Click OK.
    -This will not help until the drive is detected again.. This option might explain why the volume was listed in Everything previously.

Cevic
Posts: 4
Joined: Mon Jun 22, 2020 5:41 am

Re: Cannot index HDD

Post by Cevic » Mon Jun 22, 2020 7:21 am

While on debug mode it keeps running and running, those are the lines im getting:

https://pastebin.com/yESTDa8k

and this is the image
https://imgur.com/a/lOlu5eR

void
Site Admin
Posts: 5458
Joined: Fri Oct 16, 2009 11:31 pm

Re: Cannot index HDD

Post by void » Mon Jun 22, 2020 7:50 am

Thanks for the logs.

The logs show this volume does not have any path names.

Is this volume shown in Computer Management -> Disk Management?
From the start menu, run: compmgmt.msc
Navigate to Storage -> Disk Management.
Is the E: drive listed here?
If you right click the E: drive and click Change Drive Letter And Paths is E: listed?

Is this volume listed in diskpart?
From a command prompt, run:
diskpart
in diskpart, type in the following and press ENTER:
list volume

Please try manually adding this volume:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically remove offline volumes.
  • Click OK.
  • Completely exit Everything (right click the Everything system tray icon and click Exit).
  • Open your %APPDATA%\Everything\Everything.ini
    Change the following lines:
    ntfs_volume_guids="\\\\?\\Volume{xxx}"
    ntfs_volume_paths="C:"
    ntfs_volume_roots=""
    ntfs_volume_includes=1
    to:
    ntfs_volume_guids="\\\\?\\Volume{xxx}","\\\\?\\Volume{your-volume-guid}"
    ntfs_volume_paths="C:","E:"
    ntfs_volume_roots="",""
    ntfs_volume_includes=1,1
  • Restart Everything

Cevic
Posts: 4
Joined: Mon Jun 22, 2020 5:41 am

Re: Cannot index HDD

Post by Cevic » Mon Jun 22, 2020 8:31 am

Bingo!

the problem was that the volume wasn't listed anywhere; i updated it, rebooted and voilà fixed..


thank you for you quick and amazing support, nowadays we can't survive without everything :D

Post Reply