Need help deploying from a network share

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
DeployGuy
Posts: 2
Joined: Tue Aug 13, 2019 4:26 pm

Need help deploying from a network share

Post by DeployGuy » Tue Aug 13, 2019 4:42 pm

We have a configuration script that runs from a network share to set up a common configuration for new user machines. It installs a bunch of applications and I'd like to add Everything to that list. The machines are all Windows 10, and I need to install the Everything service on them. The configuration script runs with admin privileges and I don't mind popping up another UAC dialog during installation of Everything.

When I try using the installer, everything is configured perfectly if I install with user privileges, but once I get the script to run the installer with elevated privileges the default options are to start up everything in admin mode and not to install the service. I haven't found any way to pass any options into the installer to override this behavior.

When I try using the standalone exe, Everything successfully copies itself to the path I've specified on the local machines and restarts in admin mode, taking the options I've specified after -install-options but it fails to start the service. I checked the properties on the service and it is trying to launch the service from the network share, not the local exe. The commandline I was using for this is:

[PATH_TO_EVERYTHING_ON_SHARE]\Everything.exe -install "%ProgramFiles%\Everything" -install-options -uninstall-run-on-system-startup -install-service -install-desktop-shortcut

Any ideas what I'm doing wrong? I'm happy to use either the installer or the standalone, but I'd really want the service to be set up immediately, not requiring our non-technical users to adjust options on the first run of Everything client.

NotNull
Posts: 1591
Joined: Wed May 24, 2017 9:22 pm

Re: Need help deploying from a network share

Post by NotNull » Tue Aug 13, 2019 5:45 pm

The command-line options you used for Everything.exe are valid for the setup.exe too.

See Install options and deployment

(It looks like you already found the Command Line Options page, so no need to mention taht .. :))

DeployGuy
Posts: 2
Joined: Tue Aug 13, 2019 4:26 pm

Re: Need help deploying from a network share

Post by DeployGuy » Wed Aug 14, 2019 4:41 pm

Ahhh, thank you.

When I tried using the setup.exe, I didn't use the /S switch, thinking I could verify the options I'd set using -install-options in the installer GUI. But without /S the installer uses its defaults, so I thought it didn't support passing the options in. Hasn't seen that forum post (and also didn't see a search on the forum, though it's pretty obviously showing in the top-right today.. I must have been having a bad day yesterday.)

Anyway, it's working perfectly as you described. Thanks!

NotNull
Posts: 1591
Joined: Wed May 24, 2017 9:22 pm

Re: Need help deploying from a network share

Post by NotNull » Wed Aug 14, 2019 7:05 pm

DeployGuy wrote:
Wed Aug 14, 2019 4:41 pm
I must have been having a bad day yesterday.
If this was a bad day for you, you must be one lucky DeployGuy :)

To be honest: I didn't know this either until it was recently pointed out to me. And I should know a thing (or two) about installers ...

Glad yougot it working. :thumbsup:
(and thanks or your feedback!)

Post Reply