Syntax

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
mark_wr
Posts: 4
Joined: Wed Jul 17, 2019 10:14 pm

Syntax

Post by mark_wr » Wed Jul 17, 2019 10:22 pm

It had been a while since I updated Everything. After the update, it seems to behave differently. I've tried reading the Support pages, but my old eyes get tired fast. Here's my question. In the past I could type a drive letter, colon, space, more search terms and get results for just that drive. Ie:

d: fun

would get me a list of *fun*.* anywhere on drive d:

It does not work any more.

In the program options, is there something I should change?

Thanks, and have a great day.

therube
Posts: 2377
Joined: Thu Sep 03, 2009 6:48 pm

Re: Syntax

Post by therube » Wed Jul 17, 2019 11:06 pm

Insure that you have not inadvertently set a Search parameter, like Case or Whole Word or similar.

mark_wr
Posts: 4
Joined: Wed Jul 17, 2019 10:14 pm

Re: Syntax

Post by mark_wr » Wed Jul 17, 2019 11:37 pm

Thanks.
If you mean these options, I've tried both ways, and here here is how they are set now:

Options / Home / Match case: = Disabled
Options / Home / Match whole word: = Disabled
Options / Search / Match whole filenames when using wildcards = unchecked

btw, does that last one refer to including file extensions?

Thanks again.

therube
Posts: 2377
Joined: Thu Sep 03, 2009 6:48 pm

Re: Syntax

Post by therube » Wed Jul 17, 2019 11:48 pm

What results are returned for you with:

d: fun

?


Oh, or do you have a Filter enabled (one that would not return any results for your search)?

mark_wr
Posts: 4
Joined: Wed Jul 17, 2019 10:14 pm

Re: Syntax

Post by mark_wr » Thu Jul 18, 2019 1:08 am

If I search
fun
I get lots of results, with dozens of them on drive D:

If I search
d: fun
I get 0 results

froggie
Posts: 133
Joined: Wed Jun 12, 2013 10:43 pm

Re: Syntax

Post by froggie » Thu Jul 18, 2019 3:12 am

try checking
search>match path
or use
path:d:
instead of
d:

void
Site Admin
Posts: 4997
Joined: Fri Oct 16, 2009 11:31 pm

Re: Syntax

Post by void » Thu Jul 18, 2019 4:32 am

Please make sure no search options are checked under the Search Menu:


Please check your filters if you have accidentally set a macro to d:
  • In Everything, from the Search menu, click Organize filters.
  • For each filter in the list:
    • Click Edit....
    • Check the Macro field, is the macro set to d? -If so, please delete it.
    • Click OK.
  • Click OK.
Do the same with your bookmarks:
  • In Everything, from the Bookmark menu, click Organize bookmarks.
  • For each bookmark in the list:
    • Click Edit....
    • Check the Macro field, is the macro set to d? -If so, please delete it.
    • Click OK.
  • Click OK.

mark_wr
Posts: 4
Joined: Wed Jul 17, 2019 10:14 pm

Re: Syntax

Post by mark_wr » Thu Jul 18, 2019 11:44 am

SOLVED. Thank you. The fix was: Search / Enable Regex (changed from ON to OFF).

All other Search menu items are now also off except I had to keep "Match Path" on there.

Perhaps my fingers fumbled Ctrl+R (toggles Enable Regex) at some point. I just removed that hot key.

Post Reply