Everything dosn't display many files

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
landau
Posts: 2
Joined: Sun Jul 14, 2019 7:26 pm

Everything dosn't display many files

Post by landau » Sun Jul 14, 2019 7:32 pm

Since today (or yesterday) I try to search files but everything dosn't find them.
I think that most of the files in my computer are not concluded in the search.
I don't know how it happened.
I'll appriciate your help. :roll:

NotNull
Posts: 1364
Joined: Wed May 24, 2017 9:22 pm

Re: Everything dosn't display many files

Post by NotNull » Sun Jul 14, 2019 7:38 pm

- What happens if you press Alt-Home?
- Make sure only "Everything" is enabled under Menu:Search
- Do a Force Rebuild (under Menu:Tools > Options > Indexes

landau
Posts: 2
Joined: Sun Jul 14, 2019 7:26 pm

Re: Everything dosn't display many files

Post by landau » Sun Jul 14, 2019 8:05 pm

thanks!
the third option (force rebuild) solved the problem.
could you explain me what was the issue?

NotNull
Posts: 1364
Joined: Wed May 24, 2017 9:22 pm

Re: Everything dosn't display many files

Post by NotNull » Sun Jul 14, 2019 9:17 pm

Glad you got it working again!

Everything uses 2 different, deeply hidden, Windows files for detecting what files are on you system.
One is the "address book" of all files and the other is a logfile of all changes to the filesystem (new/changed/deleted files).

Sometimes - very rarely - Everything misses some file changes from the logfile.
A 'Force Reboot' re-reads all files from the 'address book'

Other possible explanation: your database was corrupted.

Make sure you are on a recent Everything version ( 1.4.1.935 or higher ) to minimize those misses.
If this happens again, please report back. There are fixes for that too :)

w64bit
Posts: 58
Joined: Wed Jan 09, 2013 9:06 am

Re: Everything dosn't display many files

Post by w64bit » Mon Jul 15, 2019 11:26 am

This problem is present also rarely and randomly using 947.
Is there any fix in development?
1.5 will solve this?

void
Site Admin
Posts: 4830
Joined: Fri Oct 16, 2009 11:31 pm

Re: Everything dosn't display many files

Post by void » Wed Jul 17, 2019 12:48 am

The most common cause of Everything missing files is the USN Journal used a short file name to log a file change.
Everything expects a long filename in the USN Journal.
This will be addressed in Everything 1.5.

For now, disabling 8.3 filename creation will fix the issue for new filenames.

Post Reply