Page 1 of 1

Latest Everything versions are slower when searching

Posted: Sat Apr 27, 2019 9:20 am
by papregtest
Lately, i installed Everything version 1.4.1.935.x64 and noticed it was slow when I was searching. It took a few seconds, while displaying the word "Querying" at the bottom of the window. I then tried version 1.4.1.922.x64 and got the same results.

Finally, when I reverted to 1.4.1.895.x64, everything went back to being very fast (almost instantaneous).

Has anyone noticed the same issue? Is there a fix? Should I report it as a bug?

Re: Latest Everything versions are slower when searching

Posted: Sat Apr 27, 2019 10:20 am
by void
Thanks for your post.

Everything could be paging to disk.

Are you using the same config between the two versions?

Did you notice if Everything 935 was using more ram than 895?
Are any filters active or any search options checked under the Search menu?
After you see your results in Everything and after Querying has gone, is Everything fast again after typing in a new search?

Re: Latest Everything versions are slower when searching

Posted: Sat Apr 27, 2019 10:22 am
by therube
Are you using the installed version or the zip version?

Is it possible that your settings changed between different versions?

Might you have inadvertently enabled a "slow" filter - like if you mistakenly enabled RegEx (Ctrl+R), that would be slower then not having it enabled?

Or disabled some of the Index/sort options?
Options | Indexes -> Fast size, Fast date modified, Fast path...


It was long ago, before some of those options existed, that I can remember seeing any 'query' message.


If you now go back to .935, does the slowness return?

Re: Latest Everything versions are slower when searching

Posted: Sat Apr 27, 2019 11:01 am
by papregtest
Thanks for your responses, so, answering to both of you, here it is:
void wrote:
Sat Apr 27, 2019 10:20 am
Are you using the same config between the two versions?
therube wrote:
Sat Apr 27, 2019 10:22 am
Is it possible that your settings changed between different versions?
Yes, I purposefully did not change anything.
void wrote:
Sat Apr 27, 2019 10:20 am
Did you notice if Everything 935 was using more ram than 895?
Unfortunatelly, I did not
void wrote:
Sat Apr 27, 2019 10:20 am
Are any filters active or any search options checked under the Search menu?
therube wrote:
Sat Apr 27, 2019 10:22 am
Might you have inadvertently enabled a "slow" filter - like if you mistakenly enabled RegEx (Ctrl+R), that would be slower then not having it enabled?
In all cases, I have the "match path" option selected (and searching for Everything, i.e. not just for documents.
void wrote:
Sat Apr 27, 2019 10:20 am
After you see your results in Everything and after Querying has gone, is Everything fast again after typing in a new search?
Few times it is fast but mostly it is slow
therube wrote:
Sat Apr 27, 2019 10:22 am
Are you using the installed version or the zip version?
installed version

therube wrote:
Sat Apr 27, 2019 10:22 am
Or disabled some of the Index/sort options?
Options | Indexes -> Fast size, Fast date modified, Fast path...
It was long ago, before some of those options existed, that I can remember seeing any 'query' message.
I changed nothing in the settings between the 3 installations. All fast options are selected.
therube wrote:
Sat Apr 27, 2019 10:22 am
If you now go back to .935, does the slowness return?
Yes, I tried it a few days ago, same results :(

Re: Latest Everything versions are slower when searching

Posted: Mon Apr 29, 2019 4:00 am
by void
Could you please try Everything 1.4.1.899.

Does the same issue occur?

Could you please send your debug logs when running Everything 1.4.1.935 to support@voidtools.com :
  • Completely exit Everything (Right click the Everything system tray icon and click Exit)
  • Run Everything.exe (version 1.4.1.935) with the -debug-log command line option:
    Everything.exe -debug-log
  • Please send your %TEMP%\Everything Debug Log.txt to support@voidtools.com