usb external harddrive bug?

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
b-22
Posts: 4
Joined: Thu Feb 04, 2010 11:21 am

usb external harddrive bug?

Post by b-22 » Thu Feb 04, 2010 6:42 pm

hey everybody , im having trouble to index my external harddrive , everything search engine recognize the drive station in this case L:\ but faild to index
http://www.flickr.com/photos/63232766@N ... 3/sizes/o/

i have tried different version of this programme ,but it still won't index :? the same problem i have with another usb harddrives and they all bin converted to NFTS
http://www.flickr.com/photos/63232766@N ... 8/sizes/o/

can it be that all usb local drives are connected with a usbhub?

i realy loves this programme please help !!

void
Site Admin
Posts: 4895
Joined: Fri Oct 16, 2009 11:31 pm

Re: usb external harddrive bug?

Post by void » Fri Feb 05, 2010 8:43 am

It appears "Everything" is indexing this volume.
However, there maybe some orphaned files and folders due to a damaged file system.

You can confirm this by building a fresh database in debug mode.

To rebuild the database in debug mode:
  • Exit "Everything" completely.
  • Delete your Everything.db file in your "Everything" installation folder.
  • Run "Everything" with the -debug command line option:

    Code: Select all

    C:\Program Files\Everything\Everything.exe -debug
  • Check the debug console for the following messages:

    Code: Select all

    remove excluded folders: original folder count X
    remove excluded folders: folder count after removing orphan folders Y
    remove excluded folders: original file count X
    remove excluded folders: file count after removing orphan files Y
    X is the number of files and folders before the file system has been fixed.
    Y is the number of files or folders after the file system has been fixed.

    The number of removed orphaned files or folders = X - Y

    If you have a large amount of removed orphaned files (10 or more) I would recommend:
    • Make a backup of your volume.
    • Run Check Disk with Automatically fix file system errors enabled.

b-22
Posts: 4
Joined: Thu Feb 04, 2010 11:21 am

Re: usb external harddrive bug?

Post by b-22 » Sat Feb 06, 2010 12:35 pm

hey void thanx for the Rapid reply ,but call me a noob but how to start te command line option ...cmd dont recognize this command ..C:\Program Files\Everything\Everything.exe -debug

void
Site Admin
Posts: 4895
Joined: Fri Oct 16, 2009 11:31 pm

Re: usb external harddrive bug?

Post by void » Mon Feb 08, 2010 6:04 am

Please try the following:

To launch "Everything" in debug mode:
  • Exit "Everything".
  • From the Start menu, Click Run.
  • Enter: cmd
  • Enter: cd "C:\program files\Everything"
  • Enter: everything.exe -debug
To copy the text in the debug console:
  • Right click the console title bar.
  • From the Edit menu, click Mark.
  • Select all the text with your mouse cursor.
  • Right Click to copy the selected text to your clipboard.

b-22
Posts: 4
Joined: Thu Feb 04, 2010 11:21 am

Re: usb external harddrive bug?

Post by b-22 » Mon Feb 08, 2010 8:02 pm

hey void ,this time it was working ok,now for the debug scan: it mist a couple of folders from what i can see ..further i don,t know what is coursing this :?:
but i missing here a few folders it recognize a few

http://www.flickr.com/photos/63232766@N ... 2/sizes/o/

check my early image it stuck on drive L:\

i hope this helps ..thanx void

void
Site Admin
Posts: 4895
Joined: Fri Oct 16, 2009 11:31 pm

Re: usb external harddrive bug?

Post by void » Tue Feb 09, 2010 6:15 am

As suspected, the file system is corrupt.
You can see from the debug output all your folders are missing parent folders.

I would recommend you
  1. Make a backup of the drive.
  2. Run Check Disk.
Make sure you make a backup first as Check Disk will most likely mangle your folder names and file names.

To run Check Disk:
  • Open My Computer.
  • Right click the volume in question.
  • Click Properties.
  • Click the Tools tab.
  • Click Check Now....
  • Check Automatically fix file system errors.
  • Click Start.

b-22
Posts: 4
Joined: Thu Feb 04, 2010 11:21 am

Re: usb external harddrive bug?

Post by b-22 » Tue Feb 09, 2010 11:12 pm

WHOOOEEEHAHAHAHHA!! IT WORKS :D

thanx again void your right !! it was corrupted with CHKDSK it was restoring the drive ,now i have full access with everything search engine,first i thougt it was a maxlocksperfile bug in the register,but the chkdsk took all afternoon when it was finished i reboot the pc ,and search everything works like a charm ...so thanx for your help void and thanx for this programme ;)

Post Reply