Page 1 of 1

Can't search with multiple keywords [SOLVED]

Posted: Thu Dec 28, 2017 6:28 pm
by drifter
Hi,
For some reasons I can't do searches with multiple keywords anymore (for ex : if I type "redist x64", I won't find "redist.x64").
What setting do I need to change ?
Thanks.

Re: Can't search with multiple keywords

Posted: Thu Dec 28, 2017 7:30 pm
by NotNull
First thing that comes to mind is enabled search filter or "match" criteria.
If those are enabled, you will see indicators on the right side of the Everything statusbar.
Double clicking on each will turn it of. (or use Menu:Search or right-click on the statusbar)

Another possibility is that those redist files are in a folder that you excluded from indexing (Menu:Tools > Options > Indexes > Exclusions)

Or did you type your search query literally with double quotes around it? Try it without ""

I admit, last 2 scenario's are not very likely, but you never know ...

Re: Can't search with multiple keywords

Posted: Fri Dec 29, 2017 9:22 pm
by void
Please make sure the following options are unchecked from the Search menu:
  • Uncheck Match Case.
  • Uncheck Match Whole Words.
  • Uncheck Match Path.
  • Uncheck Match Diacritics.
  • Uncheck Regex.

Re: Can't search with multiple keywords

Posted: Sat Dec 30, 2017 1:17 pm
by drifter
Thank you NotNull and void ! (lol are you enemy brothers ? :)
For some reason "enable regex" was checked (well ctrl+r and ctrl+e are pretty close from each other)
void you have a great soft and a great forum !
Happy new year !

Re: Can't search with multiple keywords

Posted: Mon Jan 01, 2018 9:45 pm
by NotNull
drifter wrote:Thank you NotNull and void ! (lol are you enemy brothers ? :)

Hahaha, now you mention it ... :lol:
I think we are arch-enemies from now on! (or complementary; haven't decided yet ... ;-))

Happy new year !

Same to you (and everyone else reading this)