Delay when opening mp3 files with Winamp

If you are experiencing problems with "Everything", post here for assistance.
Post Reply
vurtikas
Posts: 36
Joined: Fri Jan 08, 2010 11:28 am

Delay when opening mp3 files with Winamp

Post by vurtikas » Sun May 05, 2013 8:51 pm

hey guys,
i'm facing serious delays of 20 till 30 second delays when opening mp3 files from everything with my winamp player.
is there a way to solve this problem?

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: Delay when opening mp3 files with Winamp

Post by void » Mon May 06, 2013 1:57 am

How have you indexed your files? eg: NTFS, folder indexes, filelists?

Are you opening mp3 the files with Enter? or drag dropping?

Is it just mp3 files? for example, does opening a .txt file open with the delay?

vurtikas
Posts: 36
Joined: Fri Jan 08, 2010 11:28 am

Re: Delay when opening mp3 files with Winamp

Post by vurtikas » Mon May 06, 2013 8:39 am

everything runs on a windows 8 pro x64 opened as administrator
the partitions are ntfs indexed.
just checked other extensions like txt or docx. they're just fine.
noticed that pdf has some problems too when opened from everything dialog window. i see the process coming up but the file is not getting fired up.
when switching from everything directly via dialog to the path of the file itself it gets opened instantly (windows shell).
is there anything i can do to help you solving this one?
thanks in advance

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: Delay when opening mp3 files with Winamp

Post by void » Mon May 06, 2013 8:47 am

Thanks for the reply.

What version of Everything are you running?

Could you please post the debug output when you open a mp3 file?

vurtikas
Posts: 36
Joined: Fri Jan 08, 2010 11:28 am

Re: Delay when opening mp3 files with Winamp

Post by vurtikas » Mon May 06, 2013 1:52 pm

i'm using the latest beta 1.3.2.647b
you probably won't believe me but after executing everything in -debug mode the mp3 files get executed and added into winamp instantly! this never happened before EVER ... i has this problem for a long time and with previous versions of everything. this is really weird! i also did a reboot just to get sure the bug won't come back in regular mode :D don't know why this happened, maybe you do ...
the pdf problem is still present. once opened via everything i'm not able to open pdf files even via explorer shell. the process comes up but nothing happens until i kill them all and start over again via windows shell.
here's the output of the pdf thingy:

Code: Select all

enter setfocus
WM_ACTIVATE 00000001 00000000, lastfocus 00000000, current focus 00000000
leave setfocus
search '' filter ''
term 00a086d0, flags: 0140, next: 00000000, notnext: 00000000
folderop: 0, fileop: 0, term:
invalidate
found 57017 folders, size 262636, db search time taken: 0.000074 seconds
_DB_WAIT: db_get_result_count waiting...
found 450725 files, size 1837044, db search time taken: 0.000555 seconds
_DB_WAIT: db_get_result_count waited 0.000796 seconds
Updating \\?\Volume{b78afd7f-1a25-11e2-be66-806e6f6e6963} (C:):
waiting for 6 handles, isdelay 0...
update filesystem C:
updated in 0.000058 seconds
waiting for 6 handles, isdelay 1...
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000341 seconds
DeviceIoControl already complete (C:)!
waiting for 6 handles, isdelay 1...
update filesystem C:
waiting for 6 handles, isdelay 1...
updated in 0.000053 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000038 seconds
waiting for 7 handles, isdelay 0...
Updating \\?\Volume{b78afd7f-1a25-11e2-be66-806e6f6e6963} (C:):
waiting for 6 handles, isdelay 0...
update filesystem C:
updated in 0.000016 seconds
waiting for 6 handles, isdelay 1...
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000299 seconds
DeviceIoControl already complete (C:)!
waiting for 6 handles, isdelay 1...
update filesystem C:
updated in 0.000021 seconds
waiting for 6 handles, isdelay 1...
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000390 seconds
waiting for 7 handles, isdelay 0...
Updating \\?\Volume{b78afd7f-1a25-11e2-be66-806e6f6e6963} (C:):
waiting for 6 handles, isdelay 0...
update filesystem C:
updated in 0.000018 seconds
waiting for 6 handles, isdelay 1...
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000312 seconds
waiting for 7 handles, isdelay 0...
search 'i' filter ''
term 0091de00, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: i
new thread (3)
new thread (4)
found 27825 folders, size 131452, db search time taken: 0.000945 seconds
new thread (5)
found 246776 files, size 1049812, db search time taken: 0.007204 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000369 seconds
search 'im' filter ''
term 009d99c0, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: im
found 1557 folders, size 65812, db search time taken: 0.001931 seconds
found 13274 files, size 65860, db search time taken: 0.010893 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000385 seconds
search 'img' filter ''
term 03945ad0, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: img
found 56 folders, size 65808, db search time taken: 0.001833 seconds
found 4509 files, size 65824, db search time taken: 0.010715 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000334 seconds
search 'img ' filter ''
term 03945738, flags: 0140, next: 03945670, notnext: 00000000
folderop: 2, fileop: 2, term: img
term 03945670, flags: 0140, next: 00000000, notnext: 00000000
folderop: 0, fileop: 0, term:
found 56 folders, size 65808, db search time taken: 0.001917 seconds
found 4509 files, size 65824, db search time taken: 0.012147 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000378 seconds
search 'img p' filter ''
term 03945a58, flags: 0140, next: 039459b8, notnext: 00000000
folderop: 2, fileop: 2, term: img
term 039459b8, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: p
found 5 folders, size 65808, db search time taken: 0.001943 seconds
found 4020 files, size 65820, db search time taken: 0.012228 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000325 seconds
search 'img pd' filter ''
term 03945968, flags: 0140, next: 039457d8, notnext: 00000000
folderop: 2, fileop: 2, term: img
term 039457d8, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: pd
found 0 folders, size 0, db search time taken: 0.001912 seconds
found 4 files, size 65808, db search time taken: 0.012314 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000362 seconds
search 'img pdf' filter ''
term 03945670, flags: 0140, next: 039458a0, notnext: 00000000
folderop: 2, fileop: 2, term: img
term 039458a0, flags: 0140, next: 00000000, notnext: 00000000
folderop: 2, fileop: 2, term: pdf
found 0 folders, size 0, db search time taken: 0.001898 seconds
found 4 files, size 65808, db search time taken: 0.012142 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000388 seconds
Updating \\?\Volume{b78afd7f-1a25-11e2-be66-806e6f6e6963} (C:):
waiting for 6 handles, isdelay 0...
update filesystem C:
waiting for 6 handles, isdelay 1...
updated in 0.000047 seconds
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000197 seconds
selection: 1/1: F:\IFaP\SCANS\img001.pdf
exec: first expr
exec: command $exec("%1")
exec: fullfilename F:\IFaP\SCANS\img001.pdf
exec: depth 0
exec: exec "%1")
exec: depth 1
exec: got "F:\IFaP\SCANS\img001.pdf"
exec: expanded "F:\IFaP\SCANS\img001.pdf"
exec: shellexecute (idlist) file:F:\IFaP\SCANS\img001.pdf param:
Enter ShellExecuteExW
F:\IFaP\SCANS
Leave ShellExecuteExW
sub buf killed
exec: main thread regained focus
DeviceIoControl already complete (C:)!
waiting for 6 handles, isdelay 1...
update filesystem C:
updated in 0.000046 seconds
waiting for 6 handles, isdelay 1...
_DB_WAIT: _db_ready_proc waiting...
_DB_WAIT: _db_ready_proc waited 0.000411 seconds
waiting for 7 handles, isdelay 0...
WM_ACTIVATE 00000000 00000000, lastfocus 0003082c, current focus 0003082c

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: Delay when opening mp3 files with Winamp

Post by void » Tue May 07, 2013 6:01 am

Thanks for the debug output.

From the debug output, Everything is opening the files as normal the delay is probably occurring in the system that is unrelated to Everything.

Please check your system for viruses, malware etc.

vurtikas
Posts: 36
Joined: Fri Jan 08, 2010 11:28 am

Re: Delay when opening mp3 files with Winamp

Post by vurtikas » Tue May 07, 2013 11:07 am

sorry void, the system is clean. also checked it in an fresh win 8 vm and the behavior is still the same. the pdf files get opened just fine with windows explorer. opening the same file with everything the process gets stuck in background and needs to be killed manually. seems to be related to everything somehow :(

void
Site Admin
Posts: 6075
Joined: Fri Oct 16, 2009 11:31 pm

Re: Delay when opening mp3 files with Winamp

Post by void » Tue May 07, 2013 11:18 am

Thanks for the reply.

It might be an issue with launching the files as administrator.

Please try installing the Everything service and make sure you run the client without administrative privileges.

vurtikas
Posts: 36
Joined: Fri Jan 08, 2010 11:28 am

Re: Delay when opening mp3 files with Winamp

Post by vurtikas » Tue May 07, 2013 12:04 pm

that did the trick. thanks!

Post Reply