Page 1 of 1

Hotkey option for "Search As You Type"

Posted: Wed Jul 24, 2019 12:40 pm
by burgundy
I use Everything on a slow PC and sometimes "Search As You Type" works slowly.

I can go into the User Interface page in Options to disable it but that is tedious to do frequently.

Would it be possible to include "Search As You Type" as one of the commands that you can assign a hotkey?

Re: Hotkey option for "Search As You Type"

Posted: Wed Jul 24, 2019 3:19 pm
by NotNull
For now, 2 "roll your own" workarounds:

1. Using already available shortcut keys.
Everything keps track of which Options page you visited last. CTRL-P opens that page.
Almost all settings in the option pages have an ALT keyboard shortcut to activate / toggle / .. (depending on the type).
You can find those by presing the ALT key. It will show the shortcut key underlined.
In your case: Search as you type

All combined : CTRL-P , ALT - S , ENTER will toggle Search as you type
(assuming this is the only option page you visit regularly)

2. Using Bookmarks
You can also change (some) INI settings form the search bar.
To switch Search as you type OFF :
/search_as_you_type=0
+ press ENTER
To switch Search as you type ON :
/search_as_you_type=1
+ press ENTER

Put each of those in it's own Bookmark and create a keyboard shortcut per bookmark (I tested with a random CTRL-ALT-W = off ; CTRL-ALT-E = on).

To disable Search as you type: Press CTRL-ALT-W , ENTER and enter your search query
To re-enable Search as you type: Press CTRL-ALT-E , ENTER and enter your search query

2019-07-24 17_17_53-Edit Bookmark.png
2019-07-24 17_17_53-Edit Bookmark.png (15.92 KiB) Viewed 3599 times

Re: Hotkey option for "Search As You Type"

Posted: Thu Jul 25, 2019 7:53 am
by void
If you find Search As You Type making the Everything UI unresponsive, please consider reducing the max threads used by Everything:
  • In Everything, type in the following search and press ENTER:
    /max_threads=1
    where 1 is the maximum number of threads. Try increasing this to improve search performance (it is hard limited to the maximum number of logical CPUs in your system) For example, if you have 8 logical CPUs, try setting max threads to 4-7. You will need to experiment with different values to find the best performance/responsiveness for your system.
I've added a optional keyboard shortcut to toggle the Search as you type setting for the next major release.

Thanks for the suggestion.

Re: Hotkey option for "Search As You Type"

Posted: Mon Jul 29, 2019 5:21 pm
by burgundy
void wrote:
Thu Jul 25, 2019 7:53 am
If you find Search As You Type making the Everything UI unresponsive, please consider reducing the max threads used by Everything:
  • In Everything, type in the following search and press ENTER:
    /max_threads=1
    where 1 is the maximum number of threads. Try increasing this to improve search performance (it is hard limited to the maximum number of logical CPUs in your system) For example, if you have 8 logical CPUs, try setting max threads to 4-7. You will need to experiment with different values to find the best performance/responsiveness for your system.
Changing the number of threads to 1 has worked extremely well.

I have never changed this setting, so I'm now wondering if it gets changed as the result of some other activity on Everything?

Re: Hotkey option for "Search As You Type"

Posted: Tue Jul 30, 2019 8:01 am
by void
The default value for max_threads is 0, which means no limit.

What type of CPU do you have?
What version of Everything are you using? -Version 899 and later adds thread yielding which should help the unresponsiveness.
Are you running any other high CPU programs? -Increasing the base priority of Everything may help here.

Re: Hotkey option for "Search As You Type"

Posted: Fri Aug 02, 2019 10:01 pm
by burgundy
I have a very old AMD Duron 1800 processor which has no SSE2 support. I run WinXP.

The setting for max threads seems to change. I set it to "1" but some time later I noticed Everything was sluggish again so I reset max threads to "1" and it improved.

Does some action on Everything change max threads?

Re: Hotkey option for "Search As You Type"

Posted: Sun Aug 04, 2019 10:13 am
by void
Everything does not change the max_threads setting.

Please make sure Everything is saving your settings:
  • In Everything, type in the following search and press ENTER:
    /max_threads=1
  • type in the following search and press ENTER:
    about:config
  • this will open your Everything.ini with notepad, find the following line to confirm your settings have been saved:
    max_threads=1
Your CPU has only one thread, so changing max_threads should make no difference.

Try changing the priority of Everything:
  • In the Task Manager, click the Processes tab.
  • Select Everything
  • Right click Everything, under Set Priority click Below Normal.
  • If that doesn't help, try changing the Priority to Above Normal.

Re: Hotkey option for "Search As You Type"

Posted: Mon Aug 05, 2019 1:42 am
by void
The next version of Everything will also have a search delay option which may help alleviate the issue.

Re: Hotkey option for "Search As You Type"

Posted: Thu Oct 22, 2020 8:15 pm
by burgundy
void wrote:
Mon Aug 05, 2019 1:42 am
The next version of Everything will also have a search delay option which may help alleviate the issue.
Has the delay feature been implemented yet?

I couldn't find "delay" in the box for "show commands containing" in keyboard options.

Re: Hotkey option for "Search As You Type"

Posted: Fri Oct 23, 2020 5:11 am
by void
Yes. Although, Everything 1.5 is still in development.

Re: Hotkey option for "Search As You Type"

Posted: Wed Oct 28, 2020 5:39 pm
by burgundy
void wrote:
Fri Oct 23, 2020 5:11 am
Yes. Although, Everything 1.5 is still in development.
I'll keep my eyes open! Thank you so much for all the time and effort you have put into Everything. It is appreciated.