exclude external drives from indexing

General discussion related to "Everything".
Post Reply
kumar
Posts: 10
Joined: Fri Sep 27, 2019 1:16 am

exclude external drives from indexing

Post by kumar » Sat Apr 25, 2020 8:23 pm

How can I exclude and prevent external drives (USB Flash drive, external hard drives, etc.) from indexing? Can I preemptively specify to index only my C drive and nothing else?

void
Site Admin
Posts: 5367
Joined: Fri Oct 16, 2009 11:31 pm

Re: exclude external drives from indexing

Post by void » Mon Apr 27, 2020 1:31 am

To exclude new drives:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • Uncheck Automatically include new fixed volumes.
  • Uncheck Automatically include new removable volumes.
  • Click OK.
Please note that some removable NTFS volumes are reported as fixed.

To index only your C: drive:
  • In Everything, from the Tools menu, click Options.
  • Click the NTFS tab on the left.
  • For each volume that is not your C: drive:
    • Click Remove (only available if the volume is offline) or uncheck Include in database.
  • Click OK.

kumar
Posts: 10
Joined: Fri Sep 27, 2019 1:16 am

Re: exclude external drives from indexing

Post by kumar » Mon Apr 27, 2020 8:59 pm

thanks for the reply.

I think this works after the fact i.e., after I connect the drive which is not helping because per your suggestion I removed the drive and unchecked include in journal (the drive letter was F) and afterwards this same external drive showed as G and everything started indexing again and when everything runs indexing (this is another issue), it slows my computer to a crawl.

There should be a way to somehow say don't index anything other than my C: drive, maybe preemptively specify all drive letters that I don't want to index even though the drive is not connected instead of waiting for the drive letter to show up in everything options to exclude it from indexing.

therube
Posts: 2539
Joined: Thu Sep 03, 2009 6:48 pm

Re: exclude external drives from indexing

Post by therube » Tue Apr 28, 2020 6:13 pm

Just some notes I made some time back.
I'd have to review just what I did (can't do that now), what my intentions were, but it should give you something to start with.

Note the the initial
:: everything -choose-volumes
is REM'd out.
And I don't think the intent here was to run the commands sequentially (in the same batch file), but to rather run (the above) command, first (& thinking it too would need the -instance switch), then (REM that out), then run the other...


go.bat:

Code: Select all

:: this sets 'auto include fixed volumes' to '0'
:: (to NOT include them - though, FOR *NEW* volumes only,
:: i.e., any NOT *already* enumerated in Everything.ini)

:: -choose-volumes, sets the pref, then exits, immediately
:: so any other actions specified are ignored

:: note that -choose-volumes does NOT tell Everything to
:: not SCAN "known" volumes (i.e. those already in E.ini)

::   everything -choose-volumes


:: if you then wanted to do more, /then/ you would have to
:: run everything with the additional parameters wanted


everything -instance NODB -read-only
pause
exit


::   everything -nodb -instance NODB -choose-volumes

:: NOTE that the -NODB option prevents read OR write
:: of the .DB, but that does NOT stop Everything
:: from the updating of its' (in memory) index

:: ONLY -READ-ONLY does that

:: ALSO, note that Everything stores its' .ini, .db,
:: ... relative to Everything.exe, so if you start
:: Everything.exe from a relative path, say:
:: ..\..\everything.exe, its associated .ini & .db
:: will be stored in ..\..\ - not in the (CWD)

Post Reply