How to disable "Cancel current search"?

General discussion related to "Everything".
Marc2222
Posts: 15
Joined: Sat Nov 14, 2015 8:01 pm

How to disable "Cancel current search"?

Postby Marc2222 » Sun Apr 02, 2017 8:05 pm

Can be always disabled that dialog?

void
Site Admin
Posts: 3488
Joined: Fri Oct 16, 2009 11:31 pm

Re: How to disable "Cancel current search"?

Postby void » Wed Apr 05, 2017 3:17 am

Currently it can not be hidden.
This dialog is only shown if you perform an action on the Everything database while Everything is already busy.
What action did you perform to show this dialog?

I've added the ini option: cancel_delay for the next beta update.

Set this to the number of milliseconds to wait before showing the cancel dialog, or set to zero to never show the dialog.

Marc2222
Posts: 15
Joined: Sat Nov 14, 2015 8:01 pm

Re: How to disable "Cancel current search"?

Postby Marc2222 » Wed Apr 05, 2017 8:07 pm

Thank you. It does appear every time I select another window while a query is running. Maybe it is related to the amount of indexed items (in my case around 11 million)...

void
Site Admin
Posts: 3488
Joined: Fri Oct 16, 2009 11:31 pm

Re: How to disable "Cancel current search"?

Postby void » Thu Apr 06, 2017 11:01 am

It does appear every time I select another window while a query is running.


I don't have a simple fix for this unfortunately. It should improve in a future release of Everything with shared read access to the database.

I've added the ini option: cancel_delay to Everything 865b.

To disable the cancel dialog:
  • In Everything, type in the following search and press ENTER:
    /cancel_delay=0

To set the cancel dialog delay to 30 seconds:
  • In Everything, type in the following search and press ENTER:
    /cancel_delay=30000

To set the cancel dialog delay to the default of 1 second:
  • In Everything, type in the following search and press ENTER:
    /cancel_delay=1000

Marc2222
Posts: 15
Joined: Sat Nov 14, 2015 8:01 pm

Re: How to disable "Cancel current search"?

Postby Marc2222 » Fri Apr 07, 2017 5:47 pm

Not sure what's going on. Copied my current folder with Everything-1.3.3.658b.x86 and extracted "Everything-1.4.1.865b.x86.zip" into that folder. There's no loading of the database and queries are not performed so I can't test it... Tried forcing database build, start with -read -only parameters and without them.

therube
Posts: 1677
Joined: Thu Sep 03, 2009 6:48 pm

Re: How to disable "Cancel current search"?

Postby therube » Fri Apr 07, 2017 11:52 pm

Make sure that you're using the Everything Service (or right-click & run Everything.exe 'As Administrator').

Options | General -> Use Everything Service

Marc2222
Posts: 15
Joined: Sat Nov 14, 2015 8:01 pm

Re: How to disable "Cancel current search"?

Postby Marc2222 » Sat Apr 08, 2017 12:30 am

Ok I know what happened: all the drives were set to not be included in the database. Even when I created a new folder with only the executable and the lang files; no older ini settings. Attempted to run now with the older database and -read-only parameter and it was again blank. But if I run it without any parameters it starts to index the drives...
I did enabled in the beginning In options > General > Run as administrator
without change, then I realized all the drives were not set to be included in the database.

Will try the "cancel_delay" ini setting once it finishes indexing...

Marc2222
Posts: 15
Joined: Sat Nov 14, 2015 8:01 pm

Re: How to disable "Cancel current search"?

Postby Marc2222 » Sat Apr 08, 2017 12:50 am

Working great the cancel dialog is gone :)


Return to “General”